summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMehdi Dogguy <mehdi@debian.org>2015-10-16 23:39:52 +0200
committerMehdi Dogguy <mehdi@debian.org>2015-10-16 23:50:33 +0200
commitde3ae34283914fc2b13f389cbb7c01cd28d63451 (patch)
tree4430a494a15b642851a32f3fd3650511442158a0
parentea29c81c14da1399360a1ee3a1a0e7ab9790d32b (diff)
Port to ocamlnet 4.0.4
-rw-r--r--debian/changelog11
-rw-r--r--debian/control2
-rw-r--r--debian/libxmlrpc-light-ocaml-dev.ocamldoc2
-rw-r--r--debian/patches/0003-Compile-with-ocamlnet-4.0.4.patch104
-rw-r--r--debian/patches/series1
5 files changed, 118 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 5521e7f..879750b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,14 @@
+xmlrpc-light (0.6.1-4) UNRELEASED; urgency=medium
+
+ * Port to ocamlnet 4.0.4
+ - Bump minimum version requirement on ocamlnet to 4.0.4~
+ - Replace uses of Http_client by Nethttp_client
+ - Use package nethttpd instead of nethttpd-for-netcgi2 when building
+ the library and its ocamldoc documentation, in the META file as well
+ as in example and test files.
+
+ -- Mehdi Dogguy <mehdi@debian.org> Fri, 16 Oct 2015 23:37:49 +0200
+
xmlrpc-light (0.6.1-3) unstable; urgency=low
* Team upload
diff --git a/debian/control b/debian/control
index a1f9eb5..78c7f80 100644
--- a/debian/control
+++ b/debian/control
@@ -9,7 +9,7 @@ Build-Depends:
cdbs,
debhelper (>= 7),
ocaml-nox,
- libocamlnet-ocaml-dev (>= 3.3.5),
+ libocamlnet-ocaml-dev (>= 4.0.4),
libxml-light-ocaml-dev,
libnethttpd-ocaml-dev,
ocaml-findlib,
diff --git a/debian/libxmlrpc-light-ocaml-dev.ocamldoc b/debian/libxmlrpc-light-ocaml-dev.ocamldoc
index 64fcfc3..db2c80e 100644
--- a/debian/libxmlrpc-light-ocaml-dev.ocamldoc
+++ b/debian/libxmlrpc-light-ocaml-dev.ocamldoc
@@ -1 +1 @@
- -package xml-light,nethttpd-for-netcgi2
+ -package xml-light,nethttpd
diff --git a/debian/patches/0003-Compile-with-ocamlnet-4.0.4.patch b/debian/patches/0003-Compile-with-ocamlnet-4.0.4.patch
new file mode 100644
index 0000000..fb485b5
--- /dev/null
+++ b/debian/patches/0003-Compile-with-ocamlnet-4.0.4.patch
@@ -0,0 +1,104 @@
+From: Mehdi Dogguy <mehdi@debian.org>
+Date: Fri, 16 Oct 2015 23:36:37 +0200
+Subject: Compile with ocamlnet 4.0.4
+
+---
+ META | 2 +-
+ Makefile | 4 ++--
+ XmlRpc.ml | 8 ++++----
+ examples/adder/Makefile | 2 +-
+ test/test.ml | 2 +-
+ 5 files changed, 9 insertions(+), 9 deletions(-)
+
+diff --git a/META b/META
+index 9e153c9..befe597 100644
+--- a/META
++++ b/META
+@@ -1,6 +1,6 @@
+ name = "xmlrpc-light"
+ version = "0.6.1"
+ description = "XML-RPC client based on Xml-Light"
+-requires = "xml-light,netclient,nethttpd-for-netcgi2"
++requires = "xml-light,netclient,nethttpd"
+ archive(byte) = "xmlrpc-light.cma"
+ archive(native) = "xmlrpc-light.cmxa"
+diff --git a/Makefile b/Makefile
+index e7dee0b..5540de5 100644
+--- a/Makefile
++++ b/Makefile
+@@ -2,9 +2,9 @@ OCAMLMAKEFILE = OCamlMakefile
+
+ RESULT = xmlrpc-light
+ SOURCES = XmlRpcBase64.mli XmlRpcBase64.ml XmlRpcDateTime.mli XmlRpcDateTime.ml XmlRpc.mli XmlRpc.ml XmlRpcServer.mli XmlRpcServer.ml
+-PACKS = xml-light,netclient,nethttpd-for-netcgi2
++PACKS = xml-light,netclient,nethttpd
+ LIBINSTALL_FILES = XmlRpcBase64.mli XmlRpcBase64.cmi XmlRpcDateTime.mli XmlRpcDateTime.cmi XmlRpc.mli XmlRpc.cmi XmlRpcServer.mli XmlRpcServer.cmi xmlrpc-light.cma xmlrpc-light.cmxa xmlrpc-light.a
+-OCAMLDOC = ocamlfind ocamldoc -package xml-light,nethttpd-for-netcgi2
++OCAMLDOC = ocamlfind ocamldoc -package xml-light,nethttpd
+ DOC_FILES = XmlRpcBase64.mli XmlRpcDateTime.mli XmlRpc.mli XmlRpcServer.mli
+
+ all: native-code-library byte-code-library
+diff --git a/XmlRpc.ml b/XmlRpc.ml
+index b398318..9d81a79 100644
+--- a/XmlRpc.ml
++++ b/XmlRpc.ml
+@@ -414,7 +414,7 @@ object (self)
+ Neturl.string_of_url
+ (Neturl.remove_from_url ~user:true ~password:true parsed_url) in
+
+- let call = new Http_client.post_raw url xml in
++ let call = new Nethttp_client.post_raw url xml in
+ call#set_req_header "User-Agent" useragent;
+ call#set_req_header "Content-Type" "text/xml";
+ List.iter (fun (n, v) -> call#set_req_header n v) headers;
+@@ -428,12 +428,12 @@ object (self)
+ | None -> ()
+ end;
+
+- let pipeline = new Http_client.pipeline in
++ let pipeline = new Nethttp_client.pipeline in
+ pipeline#set_proxy_from_environment ();
+
+ let opt = pipeline#get_options in
+ pipeline#set_options
+- {opt with Http_client.
++ {opt with Nethttp_client.
+ connection_timeout = timeout;
+ };
+
+@@ -441,7 +441,7 @@ object (self)
+ begin
+ let opt = pipeline#get_options in
+ pipeline#set_options
+- {opt with Http_client.
++ {opt with Nethttp_client.
+ verbose_status = true;
+ verbose_request_header = true;
+ verbose_response_header = true;
+diff --git a/examples/adder/Makefile b/examples/adder/Makefile
+index 0504c93..4ef2ec3 100644
+--- a/examples/adder/Makefile
++++ b/examples/adder/Makefile
+@@ -2,7 +2,7 @@ OCAMLMAKEFILE = OCamlMakefile
+
+ RESULT = adder
+ SOURCES = adder.ml
+-PACKS = xmlrpc-light,nethttpd-for-netcgi2
++PACKS = xmlrpc-light,nethttpd
+
+ all: native-code
+
+diff --git a/test/test.ml b/test/test.ml
+index f1c919d..48e6400 100644
+--- a/test/test.ml
++++ b/test/test.ml
+@@ -21,7 +21,7 @@
+
+ #require "oUnit";;
+ #require "netclient";;
+-#require "nethttpd-for-netcgi2";;
++#require "nethttpd";;
+ #require "xml-light";;
+
+ #load "xmlrpc-light.cma";;
+--
diff --git a/debian/patches/series b/debian/patches/series
index 835c9a7..c655853 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1,3 @@
0001-Allow-installation-under-a-given-div-externally-pass.patch
0002-Compile-with-ocamlnet-3.3.5.patch
+0003-Compile-with-ocamlnet-4.0.4.patch