summaryrefslogtreecommitdiff
path: root/Makefile.noimake
diff options
context:
space:
mode:
authorMatthew Vernon <matthew@debian.org>2014-01-07 14:22:55 +0000
committerMatthew Vernon <matthew@debian.org>2014-01-07 14:22:55 +0000
commitbd23210709886d1585494c9153dfcbd938a1a767 (patch)
tree38dbfc0ac81d3e3cdd1d5a555adc9bdd75774dfd /Makefile.noimake
xtrlock (2.6) unstable; urgency=low
* patch from Simon Ruderich to correctly add hardening flags * check returns of setuid and setgid * build-depend on dpkg-dev # imported from the archive
Diffstat (limited to 'Makefile.noimake')
-rw-r--r--Makefile.noimake29
1 files changed, 29 insertions, 0 deletions
diff --git a/Makefile.noimake b/Makefile.noimake
new file mode 100644
index 0000000..460cd67
--- /dev/null
+++ b/Makefile.noimake
@@ -0,0 +1,29 @@
+# Makefile for xtrlock - X Transparent Lock
+# This Makefile provided for those of you who lack a functioning xmkmf.
+#
+# Copyright (C)1993,1994 Ian Jackson
+#
+# This is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+#
+# This is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+
+LDLIBS=-lX11
+CC=gcc
+CFLAGS=-Wall
+INSTALL=install
+
+xtrlock: xtrlock.o
+
+xtrlock.o: xtrlock.c lock.bitmap mask.bitmap patchlevel.h
+
+install: xtrlock
+ $(INSTALL) -c -m 755 xtrlock /usr/bin/X11
+
+install.man:
+ $(INSTALL) -c -m 644 xtrlock.man /usr/man/man1/xtrlock.1x