summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-10-17 08:40:22 +0200
committerRuben Undheim <ruben.undheim@gmail.com>2019-10-20 11:01:06 +0200
commit9d480edefa99f4493808b63a55a7e88ca53905f0 (patch)
treedebe1d3eb7e4fc67cd0ea6d29131280b4331bbfe
parent5c424a55a105999cd81f10a1ddfe6f7f3d144542 (diff)
Let dpkg-buildpackage handle stripping of binaries
Gbp-Pq: Name 0013-Let-dpkg-buildpackage-handle-stripping-of-binaries.patch
-rw-r--r--Makefile4
1 files changed, 0 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 6801a598..0a75c58f 100644
--- a/Makefile
+++ b/Makefile
@@ -730,20 +730,16 @@ install: $(TARGETS) $(EXTRA_TARGETS)
$(INSTALL_SUDO) mkdir -p $(DESTDIR)$(BINDIR)
$(INSTALL_SUDO) cp $(TARGETS) $(DESTDIR)$(BINDIR)
ifneq ($(filter yosys,$(TARGETS)),)
- $(INSTALL_SUDO) $(STRIP) -S $(DESTDIR)$(BINDIR)/yosys
endif
ifneq ($(filter yosys-abc,$(TARGETS)),)
- $(INSTALL_SUDO) $(STRIP) $(DESTDIR)$(BINDIR)/yosys-abc
endif
ifneq ($(filter yosys-filterlib,$(TARGETS)),)
- $(INSTALL_SUDO) $(STRIP) $(DESTDIR)$(BINDIR)/yosys-filterlib
endif
$(INSTALL_SUDO) mkdir -p $(DESTDIR)$(DATDIR)
$(INSTALL_SUDO) cp -r share/. $(DESTDIR)$(DATDIR)/.
ifeq ($(ENABLE_LIBYOSYS),1)
$(INSTALL_SUDO) mkdir -p $(DESTDIR)$(LIBDIR)
$(INSTALL_SUDO) cp libyosys.so $(DESTDIR)$(LIBDIR)/
- $(INSTALL_SUDO) $(STRIP) -S $(DESTDIR)$(LIBDIR)/libyosys.so
ifeq ($(ENABLE_PYOSYS),1)
$(INSTALL_SUDO) mkdir -p $(PYTHON_DESTDIR)/pyosys
$(INSTALL_SUDO) cp libyosys.so $(PYTHON_DESTDIR)/pyosys/