summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-07-14 21:04:01 +0200
committerRuben Undheim <ruben.undheim@gmail.com>2018-07-14 21:04:01 +0200
commit051658ab80e764dae89bdc3f9576ff7922140bd5 (patch)
treeebb4e083c5b3b7e9890897e7f55a02ca16dfbdb7
parent25cb56d09a0cc900c83dce53170e84d44daaec77 (diff)
Fix additional calls to pdflatex
-rw-r--r--debian/patches/0008-Set-fixed-date-when-calling-pdflatex-for-presentatio.patch24
1 files changed, 18 insertions, 6 deletions
diff --git a/debian/patches/0008-Set-fixed-date-when-calling-pdflatex-for-presentatio.patch b/debian/patches/0008-Set-fixed-date-when-calling-pdflatex-for-presentatio.patch
index 231b837a..f461d14f 100644
--- a/debian/patches/0008-Set-fixed-date-when-calling-pdflatex-for-presentatio.patch
+++ b/debian/patches/0008-Set-fixed-date-when-calling-pdflatex-for-presentatio.patch
@@ -5,9 +5,9 @@ Subject: Set fixed date when calling pdflatex for presentation.tex. Remove ID
---
Makefile | 2 +-
- manual/presentation.sh | 5 ++++-
+ manual/presentation.sh | 7 +++++--
manual/presentation.tex | 1 +
- 3 files changed, 6 insertions(+), 2 deletions(-)
+ 3 files changed, 7 insertions(+), 3 deletions(-)
diff --git a/Makefile b/Makefile
index 8979641..53bab9b 100644
@@ -23,21 +23,33 @@ index 8979641..53bab9b 100644
clean:
diff --git a/manual/presentation.sh b/manual/presentation.sh
-index ca8a6c9..a152484 100755
+index ca8a6c9..d1e71d8 100755
--- a/manual/presentation.sh
+++ b/manual/presentation.sh
-@@ -37,7 +37,10 @@ fi
+@@ -37,7 +37,8 @@ fi
set -ex
-pdflatex $PDFTEX_OPT presentation.tex
+echo ${PDF_DATE}
+pdflatex $PDFTEX_OPT '\pdfinfo{/CreationDate('${PDF_DATE}')/ModDate('${PDF_DATE}')}\input{presentation.tex}'
-+grep -av '^/ID \[\(<[0-9A-F]\{32\}>\) \1]$$' presentation.pdf > presentation.pdf.without_pdf_id
-+mv -f presentation.pdf.without_pdf_id presentation.pdf
if ! $fast_mode; then
while
+@@ -45,10 +46,12 @@ if ! $fast_mode; then
+ ! cmp autoloop.old autoloop.new
+ do
+ cp autoloop.new autoloop.old
+- pdflatex $PDFTEX_OPT presentation.tex
++ pdflatex $PDFTEX_OPT '\pdfinfo{/CreationDate('${PDF_DATE}')/ModDate('${PDF_DATE}')}\input{presentation.tex}'
+ done
+
+ rm -f autoloop.old
+ rm -f autoloop.new
+ fi
+
++grep -av '^/ID \[\(<[0-9A-F]\{32\}>\) \1]$' presentation.pdf > presentation.pdf.without_pdf_id
++mv -f presentation.pdf.without_pdf_id presentation.pdf
diff --git a/manual/presentation.tex b/manual/presentation.tex
index 8060998..a42648c 100644
--- a/manual/presentation.tex