summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-07-27 18:46:13 +0000
committerRuben Undheim <ruben.undheim@gmail.com>2018-08-21 21:37:46 +0200
commitb48c5e4962c1174e37c5ed7f7d7c5063ddeeeede (patch)
tree865e21aacefd616461ea0afe4ac26c98741f4404
parent813e0cc8b5b384eb32ebc8852b9d5dead14315df (diff)
Fix adding of sys.path in yosys-smtbmc
Gbp-Pq: Name 0010-Fix-adding-of-sys.path-in-yosys-smtbmc.patch
-rw-r--r--backends/smt2/Makefile.inc2
1 files changed, 1 insertions, 1 deletions
diff --git a/backends/smt2/Makefile.inc b/backends/smt2/Makefile.inc
index eacda273..f98e6104 100644
--- a/backends/smt2/Makefile.inc
+++ b/backends/smt2/Makefile.inc
@@ -6,7 +6,7 @@ ifneq ($(CONFIG),emcc)
TARGETS += yosys-smtbmc
yosys-smtbmc: backends/smt2/smtbmc.py
- $(P) sed 's|##yosys-sys-path##|sys.path += [os.path.dirname(__file__) + p for p in ["/share/python3", "/../share/yosys/python3"]]|;' < $< > $@.new
+ $(P) sed 's|##yosys-sys-path##|sys.path += ["/usr/share/yosys"]|;' < $< > $@.new
$(Q) chmod +x $@.new
$(Q) mv $@.new $@