summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-08-21 18:51:03 +0000
committerRuben Undheim <ruben.undheim@gmail.com>2018-08-21 18:51:03 +0000
commitd95d24d78f3e750a0bd96586f512da8dc0f8d614 (patch)
tree60891bcec6cb3dd1a9f1d447ce2b0debe1e2c5dc
parentd5797e6d7a22018d9e0f70670fa058e5fae8c8a4 (diff)
Fix another error in patch
-rw-r--r--debian/patches/0011-Do-not-show-g-build-flags-in-Version-string.patch4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/patches/0011-Do-not-show-g-build-flags-in-Version-string.patch b/debian/patches/0011-Do-not-show-g-build-flags-in-Version-string.patch
index 6060db15..9198b3be 100644
--- a/debian/patches/0011-Do-not-show-g-build-flags-in-Version-string.patch
+++ b/debian/patches/0011-Do-not-show-g-build-flags-in-Version-string.patch
@@ -7,7 +7,7 @@ Subject: Do not show g++ build flags in Version string
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/Makefile b/Makefile
-index aa66a54..3ff9c1b 100644
+index aa66a54..69057c2 100644
--- a/Makefile
+++ b/Makefile
@@ -370,15 +370,14 @@ libyosys.so: $(filter-out kernel/driver.o,$(OBJS))
@@ -24,7 +24,7 @@ index aa66a54..3ff9c1b 100644
yosys-config: misc/yosys-config.in
- $(P) $(SED) -e 's#@CXXFLAGS@#$(subst -I. -I"$(YOSYS_SRC)",-I"$(DATDIR)/include",$(CXXFLAGS))#;' \
-+ NEWCXXFLAGS=`echo $(subst -I. -I"$(YOSYS_SRC)",-I"$(DATDIR)/include",$(CXXFLAGS)) | sed 's/-fdebug-prefix[^ ]\+ //' | sed 's/-ffile-prefix-map[^ ]\+ //'` ; $(P) $(SED) -e 's#@CXXFLAGS@#'${NEWCXXFLAGS}'#;' \
++ NEWCXXFLAGS="`echo $(subst -I. -I"$(YOSYS_SRC)",-I"$(DATDIR)/include",$(CXXFLAGS)) | sed 's/-fdebug-prefix[^ ]\+ //' | sed 's/-ffile-prefix-map[^ ]\+ //'`" ; $(P) $(SED) -e 's#@CXXFLAGS@#'${NEWCXXFLAGS}'#;' \
-e 's#@CXX@#$(CXX)#;' -e 's#@LDFLAGS@#$(LDFLAGS)#;' -e 's#@LDLIBS@#$(LDLIBS)#;' \
-e 's#@BINDIR@#$(BINDIR)#;' -e 's#@DATDIR@#$(DATDIR)#;' < $< > yosys-config
$(Q) chmod +x yosys-config