summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-07-14 22:30:51 +0200
committerRuben Undheim <ruben.undheim@gmail.com>2018-07-14 22:32:03 +0200
commit4c778cc4954a2ca75622c303a64783146ee1c340 (patch)
tree41895ce2a51d5e6b03c03dcca2b5753aaff65797
parentd490603f5f1152ae7d343a3996da3bc164aeb4f2 (diff)
Set /CreationDate also for manual.tex
-rw-r--r--debian/patches/0011-Set-CreationDate-explicitly-for-manual.tex-also.patch49
-rw-r--r--debian/patches/series1
2 files changed, 50 insertions, 0 deletions
diff --git a/debian/patches/0011-Set-CreationDate-explicitly-for-manual.tex-also.patch b/debian/patches/0011-Set-CreationDate-explicitly-for-manual.tex-also.patch
new file mode 100644
index 00000000..ebc1bdc0
--- /dev/null
+++ b/debian/patches/0011-Set-CreationDate-explicitly-for-manual.tex-also.patch
@@ -0,0 +1,49 @@
+From: Ruben Undheim <ruben.undheim@gmail.com>
+Date: Sat, 14 Jul 2018 22:30:24 +0200
+Subject: Set \CreationDate explicitly for manual.tex also
+
+---
+ Makefile | 2 +-
+ manual/manual.sh | 6 ++++--
+ 2 files changed, 5 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 53bab9b..78f0f58 100644
+--- a/Makefile
++++ b/Makefile
+@@ -465,7 +465,7 @@ update-manual: $(TARGETS) $(EXTRA_TARGETS)
+ manual: $(TARGETS) $(EXTRA_TARGETS)
+ cd manual && bash appnotes.sh
+ cd manual && PDF_DATE=$(PDF_DATE) bash presentation.sh
+- cd manual && bash manual.sh
++ cd manual && PDF_DATE=$(PDF_DATE) bash manual.sh
+
+ clean:
+ rm -rf share
+diff --git a/manual/manual.sh b/manual/manual.sh
+index c467393..4417f56 100755
+--- a/manual/manual.sh
++++ b/manual/manual.sh
+@@ -39,7 +39,7 @@ fi
+
+ set -ex
+
+-pdflatex $PDFTEX_OPT manual.tex
++pdflatex $PDFTEX_OPT '\pdfinfo{/CreationDate('${PDF_DATE}')/ModDate('${PDF_DATE}')}\input{manual.tex}'
+
+ if ! $fast_mode; then
+ bibtex manual.aux
+@@ -50,10 +50,12 @@ if ! $fast_mode; then
+ ! cmp autoloop.old autoloop.new
+ do
+ cp autoloop.new autoloop.old
+- pdflatex $PDFTEX_OPT manual.tex
++ pdflatex $PDFTEX_OPT '\pdfinfo{/CreationDate('${PDF_DATE}')/ModDate('${PDF_DATE}')}\input{manual.tex}'
+ done
+
+ rm -f autoloop.old
+ rm -f autoloop.new
+ fi
+
++grep -av '^/ID \[\(<[0-9A-F]\{32\}>\) \1]$' manual.pdf > manual.pdf.without_pdf_id
++mv -f manual.pdf.without_pdf_id manual.pdf
diff --git a/debian/patches/series b/debian/patches/series
index 86a2e927..e9e98dd1 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -8,3 +8,4 @@ kfreebsd-support.patch
0008-Set-fixed-date-when-calling-pdflatex-for-presentatio.patch
0009-Some-spelling-errors-fixed.patch
0010-Replace-CreationDate-in-PDFs-generated-by-yosys.patch
+0011-Set-CreationDate-explicitly-for-manual.tex-also.patch