summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2016-11-03 23:21:14 +0100
committerRuben Undheim <ruben.undheim@gmail.com>2016-11-03 23:21:14 +0100
commitd3d199ba38f353f63ba0b81ac4126245d64858ea (patch)
treee773e5f2fb769872b1e7b6f5a875d79d86e6b80e
parent1075138fe86c405f85a6ea3d7c34cf9d6a1c7b0f (diff)
Refreshed patches
-rw-r--r--debian/patches/01_gitrevision.patch14
-rw-r--r--debian/patches/02_removeabc.patch2
-rw-r--r--debian/patches/03_notruntests.patch42
-rw-r--r--debian/patches/add-missing-headers.patch2
-rw-r--r--debian/patches/fix_ftbfs_cannot_find_infinite.patch2
-rw-r--r--debian/patches/kfreebsd-support.patch8
6 files changed, 34 insertions, 36 deletions
diff --git a/debian/patches/01_gitrevision.patch b/debian/patches/01_gitrevision.patch
index e9bf8645..e34ce4a0 100644
--- a/debian/patches/01_gitrevision.patch
+++ b/debian/patches/01_gitrevision.patch
@@ -7,21 +7,19 @@ Subject: Compilation from the upstream code depends on being in the git
Forwarded: doesn't make sense upstream
---
- Makefile | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
-index fd31776..da69b01 100644
+index 0a61fe6..27eb998 100644
--- a/Makefile
+++ b/Makefile
-@@ -72,8 +72,8 @@ else
- LDLIBS += -lrt
+@@ -73,7 +73,7 @@ else
endif
--YOSYS_VER := 0.6+$(shell test -e .git && { git log --author=clifford@clifford.at --oneline 5869d26da021.. | wc -l; })
+ YOSYS_VER := 0.7
-GIT_REV := $(shell cd $(YOSYS_SRC) && git rev-parse --short HEAD 2> /dev/null || echo UNKNOWN)
-+YOSYS_VER := 0.6+20160920git0c697b9
-+GIT_REV := 0c697b9
++GIT_REV := 61f6811
OBJS = kernel/version_$(GIT_REV).o
# set 'ABCREV = default' to use abc/ as it is
diff --git a/debian/patches/02_removeabc.patch b/debian/patches/02_removeabc.patch
index 522d0a53..370f640d 100644
--- a/debian/patches/02_removeabc.patch
+++ b/debian/patches/02_removeabc.patch
@@ -9,7 +9,7 @@ Forwarded: doesn't make sense upstream
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
-index da69b01..59a87c3 100644
+index 27eb998..f26a6e0 100644
--- a/Makefile
+++ b/Makefile
@@ -225,7 +225,7 @@ endif
diff --git a/debian/patches/03_notruntests.patch b/debian/patches/03_notruntests.patch
index 3348ddcb..3c677c23 100644
--- a/debian/patches/03_notruntests.patch
+++ b/debian/patches/03_notruntests.patch
@@ -8,38 +8,38 @@ Forwarded: doesn't make sense upstream
1 file changed, 16 insertions(+), 16 deletions(-)
diff --git a/Makefile b/Makefile
-index 59a87c3..351a7cc 100644
+index f26a6e0..cbbd878 100644
--- a/Makefile
+++ b/Makefile
-@@ -404,21 +404,21 @@ endif
- yosys-abc$(EXE): abc/abc-$(ABCREV)$(EXE)
- $(P) cp abc/abc-$(ABCREV)$(EXE) yosys-abc$(EXE)
+@@ -412,21 +412,21 @@ else
+ SEEDOPT=""
+ endif
-test: $(TARGETS) $(EXTRA_TARGETS)
-- +cd tests/simple && bash run-test.sh
-- +cd tests/hana && bash run-test.sh
-- +cd tests/asicworld && bash run-test.sh
-- +cd tests/realmath && bash run-test.sh
-- +cd tests/share && bash run-test.sh
-- +cd tests/fsm && bash run-test.sh
+- +cd tests/simple && bash run-test.sh $(SEEDOPT)
+- +cd tests/hana && bash run-test.sh $(SEEDOPT)
+- +cd tests/asicworld && bash run-test.sh $(SEEDOPT)
+- +cd tests/realmath && bash run-test.sh $(SEEDOPT)
+- +cd tests/share && bash run-test.sh $(SEEDOPT)
+- +cd tests/fsm && bash run-test.sh $(SEEDOPT)
- +cd tests/techmap && bash run-test.sh
-- +cd tests/memories && bash run-test.sh
-- +cd tests/bram && bash run-test.sh
+- +cd tests/memories && bash run-test.sh $(SEEDOPT)
+- +cd tests/bram && bash run-test.sh $(SEEDOPT)
- +cd tests/various && bash run-test.sh
- +cd tests/sat && bash run-test.sh
- @echo ""
- @echo " Passed \"make test\"."
- @echo ""
+#test: $(TARGETS) $(EXTRA_TARGETS)
-+# +cd tests/simple && bash run-test.sh
-+# +cd tests/hana && bash run-test.sh
-+# +cd tests/asicworld && bash run-test.sh
-+# +cd tests/realmath && bash run-test.sh
-+# +cd tests/share && bash run-test.sh
-+# +cd tests/fsm && bash run-test.sh
++# +cd tests/simple && bash run-test.sh $(SEEDOPT)
++# +cd tests/hana && bash run-test.sh $(SEEDOPT)
++# +cd tests/asicworld && bash run-test.sh $(SEEDOPT)
++# +cd tests/realmath && bash run-test.sh $(SEEDOPT)
++# +cd tests/share && bash run-test.sh $(SEEDOPT)
++# +cd tests/fsm && bash run-test.sh $(SEEDOPT)
+# +cd tests/techmap && bash run-test.sh
-+# +cd tests/memories && bash run-test.sh
-+# +cd tests/bram && bash run-test.sh
++# +cd tests/memories && bash run-test.sh $(SEEDOPT)
++# +cd tests/bram && bash run-test.sh $(SEEDOPT)
+# +cd tests/various && bash run-test.sh
+# +cd tests/sat && bash run-test.sh
+# @echo ""
@@ -48,7 +48,7 @@ index 59a87c3..351a7cc 100644
VALGRIND ?= valgrind --error-exitcode=1 --leak-check=full --show-reachable=yes --errors-for-leak-kinds=all
-@@ -551,6 +551,6 @@ echo-git-rev:
+@@ -559,6 +559,6 @@ echo-git-rev:
-include kernel/*.d
-include techlibs/*/*.d
diff --git a/debian/patches/add-missing-headers.patch b/debian/patches/add-missing-headers.patch
index 813ad4cf..839a9063 100644
--- a/debian/patches/add-missing-headers.patch
+++ b/debian/patches/add-missing-headers.patch
@@ -8,7 +8,7 @@ Subject: Include all headers needed to build the yosys plugins.
1 file changed, 1 insertion(+)
diff --git a/Makefile b/Makefile
-index 351a7cc..810f0b2 100644
+index cbbd878..caf0c18 100644
--- a/Makefile
+++ b/Makefile
@@ -292,6 +292,7 @@ $(eval $(call add_include_file,libs/sha1/sha1.h))
diff --git a/debian/patches/fix_ftbfs_cannot_find_infinite.patch b/debian/patches/fix_ftbfs_cannot_find_infinite.patch
index 9f82f5c6..b31963fa 100644
--- a/debian/patches/fix_ftbfs_cannot_find_infinite.patch
+++ b/debian/patches/fix_ftbfs_cannot_find_infinite.patch
@@ -9,7 +9,7 @@ Bug-Debian: https://bugs.debian.org/822408
2 files changed, 4 insertions(+), 7 deletions(-)
diff --git a/frontends/ast/ast.cc b/frontends/ast/ast.cc
-index fd27240..ef392bd 100644
+index 92513a2..01608d8 100644
--- a/frontends/ast/ast.cc
+++ b/frontends/ast/ast.cc
@@ -873,11 +873,7 @@ RTLIL::Const AstNode::realAsConst(int width)
diff --git a/debian/patches/kfreebsd-support.patch b/debian/patches/kfreebsd-support.patch
index 549bc22d..346ef18b 100644
--- a/debian/patches/kfreebsd-support.patch
+++ b/debian/patches/kfreebsd-support.patch
@@ -17,7 +17,7 @@ Subject: Change yosys to look for the #define constant "__unix__" instead of
7 files changed, 13 insertions(+), 13 deletions(-)
diff --git a/kernel/driver.cc b/kernel/driver.cc
-index 5cfc417..dfc7d25 100644
+index f8d00c3..45cd6ad 100644
--- a/kernel/driver.cc
+++ b/kernel/driver.cc
@@ -30,7 +30,7 @@
@@ -48,7 +48,7 @@ index 5cfc417..dfc7d25 100644
{
string filename;
diff --git a/kernel/log.cc b/kernel/log.cc
-index 3f1d888..5d78c08 100644
+index abc401f..9641e9d 100644
--- a/kernel/log.cc
+++ b/kernel/log.cc
@@ -25,7 +25,7 @@
@@ -60,7 +60,7 @@ index 3f1d888..5d78c08 100644
# include <dlfcn.h>
#endif
-@@ -278,7 +278,7 @@ void log_pop()
+@@ -280,7 +280,7 @@ void log_pop()
log_flush();
}
@@ -69,7 +69,7 @@ index 3f1d888..5d78c08 100644
void log_backtrace(const char *prefix, int levels)
{
if (levels <= 0) return;
-@@ -462,7 +462,7 @@ void log_cell(RTLIL::Cell *cell, std::string indent)
+@@ -464,7 +464,7 @@ void log_cell(RTLIL::Cell *cell, std::string indent)
// ---------------------------------------------------
// This is the magic behind the code coverage counters
// ---------------------------------------------------