summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-10-17 08:25:57 +0200
committerRuben Undheim <ruben.undheim@gmail.com>2018-10-17 08:47:05 +0200
commit55c8c4af279d78d48a3913073047e019e1d8b732 (patch)
tree86aab158ce3c97cdb05f2c794f0c9c639bbe5286
parent1d7fa91a8c82ecb52206c046c6461f6d8c0508e9 (diff)
Fix lintians
-rw-r--r--debian/control2
-rw-r--r--debian/patches/0009-Some-spelling-errors-fixed.patch44
-rwxr-xr-xdebian/rules9
-rw-r--r--debian/yosys.lintian-overrides2
4 files changed, 54 insertions, 3 deletions
diff --git a/debian/control b/debian/control
index a9e8b276..47afaa77 100644
--- a/debian/control
+++ b/debian/control
@@ -30,7 +30,7 @@ Build-Depends-Indep:
texlive-bibtex-extra,
lmodern,
graphviz
-Standards-Version: 4.2.0
+Standards-Version: 4.2.1
Vcs-Browser: https://salsa.debian.org/science-team/yosys
Vcs-Git: https://salsa.debian.org/science-team/yosys.git
Homepage: http://www.clifford.at/yosys
diff --git a/debian/patches/0009-Some-spelling-errors-fixed.patch b/debian/patches/0009-Some-spelling-errors-fixed.patch
index 05780d3b..0be0dc04 100644
--- a/debian/patches/0009-Some-spelling-errors-fixed.patch
+++ b/debian/patches/0009-Some-spelling-errors-fixed.patch
@@ -3,13 +3,42 @@ Date: Thu, 12 Jul 2018 13:41:39 +0200
Subject: Some spelling errors fixed
---
+ backends/simplec/simplec.cc | 2 +-
+ backends/table/table.cc | 2 +-
backends/verilog/verilog_backend.cc | 2 +-
+ frontends/blif/blifparse.cc | 2 +-
frontends/liberty/liberty.cc | 2 +-
manual/CHAPTER_Overview.tex | 2 +-
manual/command-reference-manual.tex | 2 +-
passes/cmds/show.cc | 2 +-
- 5 files changed, 5 insertions(+), 5 deletions(-)
+ 8 files changed, 8 insertions(+), 8 deletions(-)
+diff --git a/backends/simplec/simplec.cc b/backends/simplec/simplec.cc
+index 349bc5a..6f2ccbe 100644
+--- a/backends/simplec/simplec.cc
++++ b/backends/simplec/simplec.cc
+@@ -748,7 +748,7 @@ struct SimplecBackend : public Backend {
+ log("\n");
+ log(" write_simplec [options] [filename]\n");
+ log("\n");
+- log("Write simple C code for simulating the design. The C code writen can be used to\n");
++ log("Write simple C code for simulating the design. The C code written can be used to\n");
+ log("simulate the design in a C environment, but the purpose of this command is to\n");
+ log("generate code that works well with C-based formal verification.\n");
+ log("\n");
+diff --git a/backends/table/table.cc b/backends/table/table.cc
+index 979273d..b75169e 100644
+--- a/backends/table/table.cc
++++ b/backends/table/table.cc
+@@ -109,7 +109,7 @@ struct TableBackend : public Backend {
+ else if (cell->output(conn.first))
+ *f << "out" << "\t";
+ else
+- *f << "unkown" << "\t";
++ *f << "unknown" << "\t";
+
+ *f << log_signal(sigmap(conn.second)) << "\n";
+ }
diff --git a/backends/verilog/verilog_backend.cc b/backends/verilog/verilog_backend.cc
index ae90315..d53df2e 100644
--- a/backends/verilog/verilog_backend.cc
@@ -23,6 +52,19 @@ index ae90315..d53df2e 100644
"can't always be mapped directly to Verilog always blocks. Unintended\n"
"changes in simulation behavior are possible! Use \"proc\" to convert\n"
"processes to logic networks and registers.", log_id(module));
+diff --git a/frontends/blif/blifparse.cc b/frontends/blif/blifparse.cc
+index 034b3e7..9116b25 100644
+--- a/frontends/blif/blifparse.cc
++++ b/frontends/blif/blifparse.cc
+@@ -276,7 +276,7 @@ void parse_blif(RTLIL::Design *design, std::istream &f, std::string dff_name, bo
+
+ if(lastcell == nullptr || module == nullptr)
+ {
+- err_reason = stringf("No primative object to attach .cname %s.", p);
++ err_reason = stringf("No primitive object to attach .cname %s.", p);
+ goto error_with_reason;
+ }
+
diff --git a/frontends/liberty/liberty.cc b/frontends/liberty/liberty.cc
index 0a5bd84..e90c87a 100644
--- a/frontends/liberty/liberty.cc
diff --git a/debian/rules b/debian/rules
index 0fe416b6..a9af380a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,22 +7,29 @@ include /usr/share/dpkg/pkg-info.mk
export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
PDF_DATE := $(shell LC_ALL=C date -u -d @$(SOURCE_DATE_EPOCH) +D:%Y%m%d%H%M%SZ)
PDF_DATE2 := $(shell LC_ALL=C date -u -d @$(SOURCE_DATE_EPOCH) +"%B %d, %Y")
CHANGELOG_DATE ?= $(shell LC_ALL=C date -u -d @$(SOURCE_DATE_EPOCH) +"%d %B %Y")
%:
- PREFIX=/usr dh $@ --parallel --with=python3
+ PREFIX=/usr dh $@ --with=python3
override_dh_auto_clean:
dh_auto_clean
$(RM) debian/man/*.1
+ $(RM) Makefile.conf
override_dh_auto_configure:
make config-gcc
+override_dh_auto_install:
+ dh_auto_install
+ chmod a-x debian/tmp/usr/share/yosys/achronix/speedster22i/cells*.v
+
override_dh_install:
dh_install --fail-missing
diff --git a/debian/yosys.lintian-overrides b/debian/yosys.lintian-overrides
new file mode 100644
index 00000000..7b397082
--- /dev/null
+++ b/debian/yosys.lintian-overrides
@@ -0,0 +1,2 @@
+# Cannot be fixed because part of file format implementation
+yosys binary: spelling-error-in-binary usr/bin/yosys upto up to