summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-08-22 07:23:08 +0200
committerRuben Undheim <ruben.undheim@gmail.com>2018-08-22 07:23:08 +0200
commit633f6892cf76d35ef3d5f91e79ab65326f19fad9 (patch)
tree692dc460801c93b120da03a826bec30094eab03f
parent231ac99af2b8e1ad4f033f9250d57e944b02ad0e (diff)
parent175a74403b6e78bbf0440aeb5dc7b41102da968f (diff)
Record yosys (0.7-7) in archive suite sid
-rw-r--r--Makefile2
-rw-r--r--debian/changelog7
-rw-r--r--debian/man/.gitignore1
-rw-r--r--debian/patches/0011-Do-not-show-g-build-flags-in-Version-string.patch4
4 files changed, 10 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index fe746f55..2d4a1ff6 100644
--- a/Makefile
+++ b/Makefile
@@ -376,7 +376,7 @@ kernel/version_$(GIT_REV).cc: $(YOSYS_SRC)/Makefile
$(P) rm -f kernel/version_*.o kernel/version_*.d kernel/version_*.cc
$(Q) mkdir -p kernel && echo "namespace Yosys { extern const char *yosys_version_str; const char *yosys_version_str=\"$(YOSYS_VER_STR)\"; }" > kernel/version_$(GIT_REV).cc
-CXXFLAGS_FOR_YOSYS_CONFIG := "$(shell echo $(subst -I. -I"$(YOSYS_SRC)",-I"$(DATDIR)/include",$(CXXFLAGS)) | sed 's/-fdebug-prefix[^ ]\+ //' | sed 's/-ffile-prefix-map[^ ]\+ //')"
+CXXFLAGS_FOR_YOSYS_CONFIG := $(shell echo $(subst -I. -I"$(YOSYS_SRC)",-I"$(DATDIR)/include",$(CXXFLAGS)) | sed 's/-fdebug-prefix[^ ]\+ //' | sed 's/-ffile-prefix-map[^ ]\+ //')
yosys-config: misc/yosys-config.in
$(P) $(SED) -e 's#@CXXFLAGS@#$(CXXFLAGS_FOR_YOSYS_CONFIG)#;' \
diff --git a/debian/changelog b/debian/changelog
index e49843c0..348237a6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+yosys (0.7-7) unstable; urgency=medium
+
+ * debian/patches/0011-Do-not-show-g-build-flags-in-Version-string.patch:
+ - Do not quote CXXFLAGS_FOR_YOSYS_CONFIG (fixes build on all)
+
+ -- Ruben Undheim <ruben.undheim@gmail.com> Wed, 22 Aug 2018 07:23:08 +0200
+
yosys (0.7-6) unstable; urgency=medium
* debian/compat: level 11
diff --git a/debian/man/.gitignore b/debian/man/.gitignore
deleted file mode 100644
index f7e585b8..00000000
--- a/debian/man/.gitignore
+++ /dev/null
@@ -1 +0,0 @@
-*.1
diff --git a/debian/patches/0011-Do-not-show-g-build-flags-in-Version-string.patch b/debian/patches/0011-Do-not-show-g-build-flags-in-Version-string.patch
index 4bc67764..92bde35e 100644
--- a/debian/patches/0011-Do-not-show-g-build-flags-in-Version-string.patch
+++ b/debian/patches/0011-Do-not-show-g-build-flags-in-Version-string.patch
@@ -7,7 +7,7 @@ Subject: Do not show g++ build flags in Version string
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/Makefile b/Makefile
-index aa66a54..fe746f5 100644
+index aa66a54..2d4a1ff 100644
--- a/Makefile
+++ b/Makefile
@@ -370,15 +370,16 @@ libyosys.so: $(filter-out kernel/driver.o,$(OBJS))
@@ -22,7 +22,7 @@ index aa66a54..fe746f5 100644
$(P) rm -f kernel/version_*.o kernel/version_*.d kernel/version_*.cc
$(Q) mkdir -p kernel && echo "namespace Yosys { extern const char *yosys_version_str; const char *yosys_version_str=\"$(YOSYS_VER_STR)\"; }" > kernel/version_$(GIT_REV).cc
-+CXXFLAGS_FOR_YOSYS_CONFIG := "$(shell echo $(subst -I. -I"$(YOSYS_SRC)",-I"$(DATDIR)/include",$(CXXFLAGS)) | sed 's/-fdebug-prefix[^ ]\+ //' | sed 's/-ffile-prefix-map[^ ]\+ //')"
++CXXFLAGS_FOR_YOSYS_CONFIG := $(shell echo $(subst -I. -I"$(YOSYS_SRC)",-I"$(DATDIR)/include",$(CXXFLAGS)) | sed 's/-fdebug-prefix[^ ]\+ //' | sed 's/-ffile-prefix-map[^ ]\+ //')
+
yosys-config: misc/yosys-config.in
- $(P) $(SED) -e 's#@CXXFLAGS@#$(subst -I. -I"$(YOSYS_SRC)",-I"$(DATDIR)/include",$(CXXFLAGS))#;' \