summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSiesh1oo <siesh1oo@siesh1oo.no>2014-03-10 20:06:46 +0100
committerSiesh1oo <siesh1oo@siesh1oo.no>2014-03-13 11:29:15 +0100
commit1d0abb3ad2a85188eef6201e0a32acbcec1e78b3 (patch)
treef69f4b2a292c4d0ff232bae892d9cc2e2997779c
parent26895223a1b2528f8416d3d3ca19d540c38c3cfe (diff)
- Makefile: export PATH=${DESTDIR}/bin:$(PATH) and (DY)LD_LIBRARY_PATH, to make sure our local copies of built executables and libraries are used.
- Makefile: use find expression in target 'yosys-svgviewer' to find svgviewer binary (qmake will build into .app package on OSX). - Makefile: make 'test' target dependent on $(TARGETS) and $(EXTRA_TARGETS) to make sure that minisat is built.
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 035f7c5a..39b324b4 100644
--- a/Makefile
+++ b/Makefile
@@ -26,13 +26,17 @@ CXXFLAGS = -Wall -Wextra -ggdb -I"$(shell pwd)" -I${DESTDIR}/include -MD -D_YOSY
LDFLAGS = -L${DESTDIR}/lib
LDLIBS = -lstdc++ -lreadline -lm -ldl
+export PATH := ${DESTDIR}/bin:$(PATH)
+
ifeq (Darwin,$(findstring Darwin,$(shell uname)))
# add macports include and library path to search directories, don't use '-rdynamic' and '-lrt':
+ export DYLD_LIBRARY_PATH := ${DESTDIR}/lib:$(DYLD_LIBRARY_PATH)
CXXFLAGS += -I/opt/local/include
LDFLAGS += -L/opt/local/lib
QMAKE = qmake
SED = gsed
else
+ export LD_LIBRARY_PATH := ${DESTDIR}/lib:$(LD_LIBRARY_PATH)
LDFLAGS += -rdynamic
LDLIBS += -lrt
QMAKE = qmake-qt4