summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSiesh1oo <siesh1oo@siesh1oo.no>2014-03-12 18:33:37 +0100
committerSiesh1oo <siesh1oo@siesh1oo.no>2014-03-13 11:29:11 +0100
commit26895223a1b2528f8416d3d3ca19d540c38c3cfe (patch)
tree87188bf705378ab6e6ab19a5041897a4a8891f37
parentc621bfa746b1ca2d698b09d7b9e65da9d191a39b (diff)
- kernel/register.h, kernel/driver.cc: refactor rewrite_yosys_exe()/get_share_file_name() to portable proc_self_dirname()/proc_share_dirname().
This refactoring improves robustness and allows OSX support with only 7 new lines of code, and easy extension for other systems. - passes/abc/abc.cc, passes/cmds/show.cc, passes/techmap/techmap.cc: use new, refactored semantics. - Makefile: no need to add $(PWD) to $(PATH) anymore.
-rw-r--r--Makefile2
1 files changed, 0 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 1eef767b..035f7c5a 100644
--- a/Makefile
+++ b/Makefile
@@ -26,8 +26,6 @@ CXXFLAGS = -Wall -Wextra -ggdb -I"$(shell pwd)" -I${DESTDIR}/include -MD -D_YOSY
LDFLAGS = -L${DESTDIR}/lib
LDLIBS = -lstdc++ -lreadline -lm -ldl
-export PATH := $(PWD):$(DESTDIR)/bin:$(PATH)
-
ifeq (Darwin,$(findstring Darwin,$(shell uname)))
# add macports include and library path to search directories, don't use '-rdynamic' and '-lrt':
CXXFLAGS += -I/opt/local/include