summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2014-07-24 17:53:11 +0200
committerClifford Wolf <clifford@clifford.at>2014-07-24 17:53:11 +0200
commit38afbe62ef61bd9b1aa92575cad7ff1785ce5e0e (patch)
treea9575af07f6a260f938d1594115383c1692c2a0f
parentb17d6531c833f9064c5888c694aa24e8a395b72a (diff)
Added percentage display to "make PRETTY=1"
-rw-r--r--Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index d57d02b2..a962c7e3 100644
--- a/Makefile
+++ b/Makefile
@@ -108,7 +108,9 @@ LDLIBS += $(patsubst %,$(VERIFIC_DIR)/%/*-linux.a,$(VERIFIC_COMPONENTS))
endif
ifeq ($(PRETTY), 1)
-P = @echo "Building $@";
+I = 0
+P = @echo "$(eval I=$(shell bash -c 'i=0; for x in $(OBJS) yosys; do ((i++)); [ "$$x" = "$@" -a $I -lt $$i ] && echo $$i && exit; done; echo $I'))[$(shell \
+ gawk "BEGIN { N=`echo $(OBJS) yosys | wc -w`; printf \"%3d\", 100*$I/N; exit; }")%] Building $@";
Q = @
S = -s
endif