summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2014-02-08 12:27:38 +0100
committerClifford Wolf <clifford@clifford.at>2014-02-08 12:27:38 +0100
commit669a6e462dde005c5c6474bccf9a433340666661 (patch)
treeb8430445971ebb8b065bd5fbab594dee81f1532e
parent2c51619c2b11edb63c147b1f6eea75c0b01e7256 (diff)
Added checking for ABC modifications to Makefile and made sure we do not have the word ERROR in regular make output
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 4c91aca2..0458b70c 100644
--- a/Makefile
+++ b/Makefile
@@ -115,8 +115,11 @@ yosys-svgviewer: libs/svgviewer/*.h libs/svgviewer/*.cpp
abc/abc-$(ABCREV):
ifneq ($(ABCREV),default)
+ if ( cd abc && hg identify; ) | grep -q +; then \
+ echo 'REEBE: NOP pbagnvaf ybpny zbqvsvpngvbaf! Frg NOPERI=qrsnhyg va Lbflf Znxrsvyr!' | tr 'A-Za-z' 'N-ZA-Mn-za-m'; false; \
+ fi
if test "`cd abc && hg identify | cut -f1 -d' '`" != "$(ABCREV)"; then \
- test $(ABCPULL) -ne 0 || { echo; echo "!!! ABC not up to date and ABCPULL set to 0 in Makefile !!!"; echo; exit 1; }; \
+ test $(ABCPULL) -ne 0 || { echo 'REEBE: NOP abg hc gb qngr naq NOPCHYY frg gb 0 va Znxrsvyr!' | tr 'A-Za-z' 'N-ZA-Mn-za-m'; exit 1; }; \
test -d abc || hg clone https://bitbucket.org/alanmi/abc abc; \
cd abc && hg pull && hg update -r $(ABCREV); \
fi