summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2014-03-11 14:52:37 +0100
committerClifford Wolf <clifford@clifford.at>2014-03-11 14:52:37 +0100
commit9087ece97c20d76359fb23cfd7a0f13552c1f2fd (patch)
treed9144191ed331346c0f5538b1d17f4a6ed636761
parent7aa2d746b76a354daedd4c8a7b4d8c15b1805b21 (diff)
OSX compatible creation of stdcells.inc, using code from github.com/Siesh1oo/yosys
(see https://github.com/cliffordwolf/yosys/pull/28)
-rw-r--r--passes/techmap/Makefile.inc5
1 files changed, 3 insertions, 2 deletions
diff --git a/passes/techmap/Makefile.inc b/passes/techmap/Makefile.inc
index ae1ebbb5..85d580ce 100644
--- a/passes/techmap/Makefile.inc
+++ b/passes/techmap/Makefile.inc
@@ -11,8 +11,9 @@ GENFILES += passes/techmap/stdcells.inc
passes/techmap/stdcells.inc: techlibs/common/stdcells.v
echo "// autogenerated from $<" > $@.new
- od -v -td1 -w1 $< | awk 'BEGIN { print "static char stdcells_code[] = {"; } $$2 != "" { print $$2 ","; } \
- END { print 0 "};"; }' | fmt >> $@.new
+ echo "static char stdcells_code[] = {" >> $@.new
+ od -v -td1 -An $< | $(SED) -e 's/[0-9][0-9]*/&,/g' >> $@.new
+ echo "0};" >> $@.new
mv $@.new $@
passes/techmap/techmap.o: passes/techmap/stdcells.inc