summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2013-11-19 23:13:41 +0100
committerClifford Wolf <clifford@clifford.at>2013-11-19 23:13:41 +0100
commita1353ec61b00442bb5ebe9f30408324b89cf6a82 (patch)
treea9a8a8909d7b73d1cee9d86a842278fc6788d9d8
parent0c91f890c9d0d93822bfaf6af6e0755b9f0d2c51 (diff)
Added "make config-sudo"
-rw-r--r--Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index 37e507fe..9a8bd940 100644
--- a/Makefile
+++ b/Makefile
@@ -8,7 +8,8 @@ ENABLE_QT4 := 1
ENABLE_MINISAT := 1
ENABLE_GPROF := 0
-DESTDIR = /usr/local
+DESTDIR := /usr/local
+INSTALL_SUDO :=
OBJS =
GENFILES =
@@ -112,13 +113,13 @@ test: yosys
cd tests/asicworld && bash run-test.sh
install: $(TARGETS)
- mkdir -p $(DESTDIR)/bin
- install $(TARGETS) $(DESTDIR)/bin/
- mkdir -p $(DESTDIR)/share/yosys
- cp -r share/. $(DESTDIR)/share/yosys/.
+ $(INSTALL_SUDO) mkdir -p $(DESTDIR)/bin
+ $(INSTALL_SUDO) install $(TARGETS) $(DESTDIR)/bin/
+ $(INSTALL_SUDO) mkdir -p $(DESTDIR)/share/yosys
+ $(INSTALL_SUDO) cp -r share/. $(DESTDIR)/share/yosys/.
install-abc:
- install yosys-abc $(DESTDIR)/bin/
+ $(INSTALL_SUDO) install yosys-abc $(DESTDIR)/bin/
manual:
cd manual && bash make.sh
@@ -157,6 +158,9 @@ config-gprof: clean
echo 'CONFIG := release' > Makefile.conf
echo 'ENABLE_GPROF := 1' >> Makefile.conf
+config-sudo:
+ echo "INSTALL_SUDO := sudo" >> Makefile.conf
+
-include libs/*/*.d
-include frontends/*/*.d
-include passes/*/*.d