summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2014-12-30 11:41:24 +0100
committerClifford Wolf <clifford@clifford.at>2014-12-30 11:41:24 +0100
commitc64b1de11da8db9e912e0a293d5c9c8a9bc31096 (patch)
tree8ff348b1fed8a2a43982480d248a5e7c8e42a62f
parentd72a66644035d43f81afa78283ecf15c520909ec (diff)
Fixed build with SMALL=1
-rw-r--r--passes/opt/Makefile.inc3
-rw-r--r--passes/techmap/Makefile.inc2
-rw-r--r--techlibs/common/Makefile.inc2
3 files changed, 6 insertions, 1 deletions
diff --git a/passes/opt/Makefile.inc b/passes/opt/Makefile.inc
index 3a8d27f9..6b075cd9 100644
--- a/passes/opt/Makefile.inc
+++ b/passes/opt/Makefile.inc
@@ -6,6 +6,9 @@ OBJS += passes/opt/opt_reduce.o
OBJS += passes/opt/opt_rmdff.o
OBJS += passes/opt/opt_clean.o
OBJS += passes/opt/opt_const.o
+
+ifneq ($(SMALL),1)
OBJS += passes/opt/share.o
OBJS += passes/opt/wreduce.o
+endif
diff --git a/passes/techmap/Makefile.inc b/passes/techmap/Makefile.inc
index 773a099a..d8a43316 100644
--- a/passes/techmap/Makefile.inc
+++ b/passes/techmap/Makefile.inc
@@ -2,13 +2,13 @@
OBJS += passes/techmap/techmap.o
OBJS += passes/techmap/simplemap.o
OBJS += passes/techmap/dfflibmap.o
+OBJS += passes/techmap/maccmap.o
OBJS += passes/techmap/libparse.o
ifneq ($(SMALL),1)
OBJS += passes/techmap/iopadmap.o
OBJS += passes/techmap/hilomap.o
OBJS += passes/techmap/extract.o
-OBJS += passes/techmap/maccmap.o
OBJS += passes/techmap/alumacc.o
OBJS += passes/techmap/dff2dffe.o
endif
diff --git a/techlibs/common/Makefile.inc b/techlibs/common/Makefile.inc
index 7c8cc2f6..0607ca1a 100644
--- a/techlibs/common/Makefile.inc
+++ b/techlibs/common/Makefile.inc
@@ -1,5 +1,7 @@
+ifneq ($(SMALL),1)
OBJS += techlibs/common/synth.o
+endif
EXTRA_TARGETS += techlibs/common/blackbox.v