summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2019-10-18 20:01:35 +0000
committerRuben Undheim <ruben.undheim@gmail.com>2019-10-18 20:01:35 +0000
commitde8796aa3a94b51ea6bbb5051215f63152671a72 (patch)
tree8bacf2c0c1a78c0d4f3669b1a4f3abb80fcbbd93
parentb9e09c69c0570486f3f8a73499049b636a4b4c34 (diff)
Changelog entry and refresh patches
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/0007-Disable-pretty-build.patch4
-rw-r--r--debian/patches/0009-Some-spelling-errors-fixed.patch26
-rw-r--r--debian/patches/0010-Fix-reproducibility-of-PDF-documents-in-yosys-doc.patch4
-rw-r--r--debian/patches/0011-Do-not-show-g-build-flags-in-Version-string.patch6
-rw-r--r--debian/patches/0012-Skip-non-deterministic-test-causing-random-FTBFS-on-.patch4
-rw-r--r--debian/patches/0013-Let-dpkg-buildpackage-handle-stripping-of-binaries.patch13
-rw-r--r--debian/patches/01_gitrevision.patch14
-rw-r--r--debian/patches/02_removeabc.patch4
-rw-r--r--debian/patches/05_abc_executable.patch4
-rw-r--r--debian/patches/kfreebsd-support.patch28
11 files changed, 51 insertions, 63 deletions
diff --git a/debian/changelog b/debian/changelog
index 29cf88ad..116c60d5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+yosys (0.9.1) UNRELEASED; urgency=medium
+
+ * New upstream release
+ - Refreshed patches
+
+ -- Ruben Undheim <ruben.undheim@gmail.com> Fri, 18 Oct 2019 20:00:57 +0000
+
yosys (0.8+20190328git32bd0f2-1~exp1) experimental; urgency=low
* New upstream GIT HEAD
diff --git a/debian/patches/0007-Disable-pretty-build.patch b/debian/patches/0007-Disable-pretty-build.patch
index 22e31cbc..03269c47 100644
--- a/debian/patches/0007-Disable-pretty-build.patch
+++ b/debian/patches/0007-Disable-pretty-build.patch
@@ -7,10 +7,10 @@ Subject: Disable pretty build
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
-index 383f6a5..0205d18 100644
+index da1b73f..065f4f2 100644
--- a/Makefile
+++ b/Makefile
-@@ -53,7 +53,7 @@ EXTRA_OBJS =
+@@ -61,7 +61,7 @@ EXTRA_OBJS =
EXTRA_TARGETS =
TARGETS = yosys$(EXE) yosys-config
diff --git a/debian/patches/0009-Some-spelling-errors-fixed.patch b/debian/patches/0009-Some-spelling-errors-fixed.patch
index 32c7c896..339c2da3 100644
--- a/debian/patches/0009-Some-spelling-errors-fixed.patch
+++ b/debian/patches/0009-Some-spelling-errors-fixed.patch
@@ -6,14 +6,13 @@ Subject: Some spelling errors fixed
frontends/ast/genrtlil.cc | 2 +-
manual/CHAPTER_Overview.tex | 2 +-
manual/command-reference-manual.tex | 2 +-
- techlibs/xilinx/synth_xilinx.cc | 4 ++--
- 4 files changed, 5 insertions(+), 5 deletions(-)
+ 3 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/frontends/ast/genrtlil.cc b/frontends/ast/genrtlil.cc
-index b3a2a84..6ec7227 100644
+index 571ddd9..cee344a 100644
--- a/frontends/ast/genrtlil.cc
+++ b/frontends/ast/genrtlil.cc
-@@ -557,7 +557,7 @@ struct AST_INTERNAL::ProcessGenerator
+@@ -558,7 +558,7 @@ struct AST_INTERNAL::ProcessGenerator
break;
case AST_ASSIGN:
@@ -23,7 +22,7 @@ index b3a2a84..6ec7227 100644
case AST_PARAMETER:
diff --git a/manual/CHAPTER_Overview.tex b/manual/CHAPTER_Overview.tex
-index 2feb0f1..c7d1d5c 100644
+index 3009bf2..4136efe 100644
--- a/manual/CHAPTER_Overview.tex
+++ b/manual/CHAPTER_Overview.tex
@@ -240,7 +240,7 @@ An RTLIL::Wire object has the following properties:
@@ -48,20 +47,3 @@ index bed6326..eb43467 100644
-signed
mark ports (A, B) that are declared as signed (using the [AB]_SIGNED
-diff --git a/techlibs/xilinx/synth_xilinx.cc b/techlibs/xilinx/synth_xilinx.cc
-index 805ae8e..0b8d833 100644
---- a/techlibs/xilinx/synth_xilinx.cc
-+++ b/techlibs/xilinx/synth_xilinx.cc
-@@ -64,10 +64,10 @@ struct SynthXilinxPass : public Pass
- log(" (this feature is experimental and incomplete)\n");
- log("\n");
- log(" -nobram\n");
-- log(" disable infering of block rams\n");
-+ log(" disable inferring of block rams\n");
- log("\n");
- log(" -nodram\n");
-- log(" disable infering of distributed rams\n");
-+ log(" disable inferring of distributed rams\n");
- log("\n");
- log(" -run <from_label>:<to_label>\n");
- log(" only run the commands between the labels (see below). an empty\n");
diff --git a/debian/patches/0010-Fix-reproducibility-of-PDF-documents-in-yosys-doc.patch b/debian/patches/0010-Fix-reproducibility-of-PDF-documents-in-yosys-doc.patch
index 33bbedc3..2f16462a 100644
--- a/debian/patches/0010-Fix-reproducibility-of-PDF-documents-in-yosys-doc.patch
+++ b/debian/patches/0010-Fix-reproducibility-of-PDF-documents-in-yosys-doc.patch
@@ -11,10 +11,10 @@ Subject: Fix reproducibility of PDF documents in yosys-doc
5 files changed, 21 insertions(+), 8 deletions(-)
diff --git a/Makefile b/Makefile
-index 0205d18..6f8c067 100644
+index 065f4f2..8608472 100644
--- a/Makefile
+++ b/Makefile
-@@ -651,9 +651,9 @@ update-manual: $(TARGETS) $(EXTRA_TARGETS)
+@@ -766,9 +766,9 @@ update-manual: $(TARGETS) $(EXTRA_TARGETS)
cd manual && ../yosys -p 'help -write-tex-command-reference-manual'
manual: $(TARGETS) $(EXTRA_TARGETS)
diff --git a/debian/patches/0011-Do-not-show-g-build-flags-in-Version-string.patch b/debian/patches/0011-Do-not-show-g-build-flags-in-Version-string.patch
index af0015d8..00e41f64 100644
--- a/debian/patches/0011-Do-not-show-g-build-flags-in-Version-string.patch
+++ b/debian/patches/0011-Do-not-show-g-build-flags-in-Version-string.patch
@@ -7,10 +7,10 @@ Subject: Do not show g++ build flags in Version string
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/Makefile b/Makefile
-index 6f8c067..5024349 100644
+index 8608472..1f8d5a2 100644
--- a/Makefile
+++ b/Makefile
-@@ -514,8 +514,7 @@ libyosys.so: $(filter-out kernel/driver.o,$(OBJS))
+@@ -612,8 +612,7 @@ endif
$(Q) mkdir -p $(dir $@)
$(P) $(CXX) -o $@ -c $(CPPFLAGS) $(CXXFLAGS) $<
@@ -20,7 +20,7 @@ index 6f8c067..5024349 100644
kernel/version_$(GIT_REV).cc: $(YOSYS_SRC)/Makefile
$(P) rm -f kernel/version_*.o kernel/version_*.d kernel/version_*.cc
-@@ -529,8 +528,10 @@ CXXFLAGS_NOVERIFIC = $(CXXFLAGS)
+@@ -627,8 +626,10 @@ CXXFLAGS_NOVERIFIC = $(CXXFLAGS)
LDLIBS_NOVERIFIC = $(LDLIBS)
endif
diff --git a/debian/patches/0012-Skip-non-deterministic-test-causing-random-FTBFS-on-.patch b/debian/patches/0012-Skip-non-deterministic-test-causing-random-FTBFS-on-.patch
index fffd15ce..9d54763a 100644
--- a/debian/patches/0012-Skip-non-deterministic-test-causing-random-FTBFS-on-.patch
+++ b/debian/patches/0012-Skip-non-deterministic-test-causing-random-FTBFS-on-.patch
@@ -8,10 +8,10 @@ Subject: Skip non-deterministic test causing random FTBFS on some
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
-index 5024349..2ed9f0f 100644
+index 1f8d5a2..6801a59 100644
--- a/Makefile
+++ b/Makefile
-@@ -576,7 +576,7 @@ test: $(TARGETS) $(EXTRA_TARGETS)
+@@ -680,7 +680,7 @@ test: $(TARGETS) $(EXTRA_TARGETS)
+cd tests/simple && bash run-test.sh $(SEEDOPT)
+cd tests/hana && bash run-test.sh $(SEEDOPT)
+cd tests/asicworld && bash run-test.sh $(SEEDOPT)
diff --git a/debian/patches/0013-Let-dpkg-buildpackage-handle-stripping-of-binaries.patch b/debian/patches/0013-Let-dpkg-buildpackage-handle-stripping-of-binaries.patch
index 35b623f7..a62c7d26 100644
--- a/debian/patches/0013-Let-dpkg-buildpackage-handle-stripping-of-binaries.patch
+++ b/debian/patches/0013-Let-dpkg-buildpackage-handle-stripping-of-binaries.patch
@@ -7,10 +7,10 @@ Subject: Let dpkg-buildpackage handle stripping of binaries
1 file changed, 4 deletions(-)
diff --git a/Makefile b/Makefile
-index 2ed9f0f..b4aac53 100644
+index 6801a59..0a75c58 100644
--- a/Makefile
+++ b/Makefile
-@@ -625,19 +625,15 @@ install: $(TARGETS) $(EXTRA_TARGETS)
+@@ -730,20 +730,16 @@ install: $(TARGETS) $(EXTRA_TARGETS)
$(INSTALL_SUDO) mkdir -p $(DESTDIR)$(BINDIR)
$(INSTALL_SUDO) cp $(TARGETS) $(DESTDIR)$(BINDIR)
ifneq ($(filter yosys,$(TARGETS)),)
@@ -25,8 +25,9 @@ index 2ed9f0f..b4aac53 100644
$(INSTALL_SUDO) mkdir -p $(DESTDIR)$(DATDIR)
$(INSTALL_SUDO) cp -r share/. $(DESTDIR)$(DATDIR)/.
ifeq ($(ENABLE_LIBYOSYS),1)
- $(INSTALL_SUDO) cp libyosys.so $(DESTDIR)$(LIBDIR)
+ $(INSTALL_SUDO) mkdir -p $(DESTDIR)$(LIBDIR)
+ $(INSTALL_SUDO) cp libyosys.so $(DESTDIR)$(LIBDIR)/
- $(INSTALL_SUDO) $(STRIP) -S $(DESTDIR)$(LIBDIR)/libyosys.so
- $(INSTALL_SUDO) ldconfig
- endif
-
+ ifeq ($(ENABLE_PYOSYS),1)
+ $(INSTALL_SUDO) mkdir -p $(PYTHON_DESTDIR)/pyosys
+ $(INSTALL_SUDO) cp libyosys.so $(PYTHON_DESTDIR)/pyosys/
diff --git a/debian/patches/01_gitrevision.patch b/debian/patches/01_gitrevision.patch
index fd31dbbf..222d1363 100644
--- a/debian/patches/01_gitrevision.patch
+++ b/debian/patches/01_gitrevision.patch
@@ -7,21 +7,19 @@ Subject: Compilation from the upstream code depends on being in the git
Forwarded: doesn't make sense upstream
---
- Makefile | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
-index 8586e97..ea66859 100644
+index a673154..d779dc0 100644
--- a/Makefile
+++ b/Makefile
-@@ -101,8 +101,8 @@ LDFLAGS += -rdynamic
- LDLIBS += -lrt
+@@ -115,7 +115,7 @@ LDLIBS += -lrt
endif
--YOSYS_VER := 0.8+$(shell cd $(YOSYS_SRC) && test -e .git && { git log --author=clifford@clifford.at --oneline 4d4665b.. 2> /dev/null | wc -l; })
+ YOSYS_VER := 0.9
-GIT_REV := $(shell cd $(YOSYS_SRC) && git rev-parse --short HEAD 2> /dev/null || echo UNKNOWN)
-+YOSYS_VER := 0.8+20190328git32bd0f2
-+GIT_REV := 32bd0f2
++GIT_REV := 1979e0b
OBJS = kernel/version_$(GIT_REV).o
# set 'ABCREV = default' to use abc/ as it is
diff --git a/debian/patches/02_removeabc.patch b/debian/patches/02_removeabc.patch
index 8ef43852..e1cb8ca5 100644
--- a/debian/patches/02_removeabc.patch
+++ b/debian/patches/02_removeabc.patch
@@ -9,10 +9,10 @@ Forwarded: doesn't make sense upstream
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
-index ea66859..383f6a5 100644
+index d779dc0..da1b73f 100644
--- a/Makefile
+++ b/Makefile
-@@ -356,7 +356,7 @@ LDLIBS += -lpthread
+@@ -440,7 +440,7 @@ LDLIBS += -lpthread
endif
else
ifeq ($(ABCEXTERNAL),)
diff --git a/debian/patches/05_abc_executable.patch b/debian/patches/05_abc_executable.patch
index a59741fc..ef774d46 100644
--- a/debian/patches/05_abc_executable.patch
+++ b/debian/patches/05_abc_executable.patch
@@ -11,10 +11,10 @@ Forwarded: doesn't make sense upstream
1 file changed, 1 insertion(+), 5 deletions(-)
diff --git a/passes/techmap/abc.cc b/passes/techmap/abc.cc
-index 21b70f4..1b36261 100644
+index bf05c68..75daaa6 100644
--- a/passes/techmap/abc.cc
+++ b/passes/techmap/abc.cc
-@@ -1458,11 +1458,7 @@ struct AbcPass : public Pass {
+@@ -1472,11 +1472,7 @@ struct AbcPass : public Pass {
pi_map.clear();
po_map.clear();
diff --git a/debian/patches/kfreebsd-support.patch b/debian/patches/kfreebsd-support.patch
index ba4fb8c1..3f8938be 100644
--- a/debian/patches/kfreebsd-support.patch
+++ b/debian/patches/kfreebsd-support.patch
@@ -16,7 +16,7 @@ Subject: Change yosys to look for the #define constant "__unix__" instead of
6 files changed, 12 insertions(+), 12 deletions(-)
diff --git a/kernel/driver.cc b/kernel/driver.cc
-index a0bb7e6..0ea5505 100644
+index f273057..edec776 100644
--- a/kernel/driver.cc
+++ b/kernel/driver.cc
@@ -34,7 +34,7 @@
@@ -28,7 +28,7 @@ index a0bb7e6..0ea5505 100644
# include <sys/resource.h>
# include <sys/types.h>
# include <unistd.h>
-@@ -456,7 +456,7 @@ int main(int argc, char **argv)
+@@ -466,7 +466,7 @@ int main(int argc, char **argv)
if (print_stats)
log_hasher = new SHA1;
@@ -37,7 +37,7 @@ index a0bb7e6..0ea5505 100644
// set stack size to >= 128 MB
{
struct rlimit rl;
-@@ -546,7 +546,7 @@ int main(int argc, char **argv)
+@@ -560,7 +560,7 @@ int main(int argc, char **argv)
#else
std::string meminfo;
std::string stats_divider = ", ";
@@ -46,7 +46,7 @@ index a0bb7e6..0ea5505 100644
std::ifstream statm;
statm.open(stringf("/proc/%lld/statm", (long long)getpid()));
if (statm.is_open()) {
-@@ -613,7 +613,7 @@ int main(int argc, char **argv)
+@@ -627,7 +627,7 @@ int main(int argc, char **argv)
}
}
@@ -56,7 +56,7 @@ index a0bb7e6..0ea5505 100644
{
string filename;
diff --git a/kernel/log.cc b/kernel/log.cc
-index 400a549..757a49c 100644
+index a782095..311bc38 100644
--- a/kernel/log.cc
+++ b/kernel/log.cc
@@ -25,7 +25,7 @@
@@ -68,7 +68,7 @@ index 400a549..757a49c 100644
# include <dlfcn.h>
#endif
-@@ -393,7 +393,7 @@ void log_pop()
+@@ -420,7 +420,7 @@ void log_pop()
log_flush();
}
@@ -77,7 +77,7 @@ index 400a549..757a49c 100644
void log_backtrace(const char *prefix, int levels)
{
if (levels <= 0) return;
-@@ -588,7 +588,7 @@ void log_wire(RTLIL::Wire *wire, std::string indent)
+@@ -615,7 +615,7 @@ void log_wire(RTLIL::Wire *wire, std::string indent)
// ---------------------------------------------------
// This is the magic behind the code coverage counters
// ---------------------------------------------------
@@ -87,10 +87,10 @@ index 400a549..757a49c 100644
dict<std::string, std::pair<std::string, int>> extra_coverage_data;
diff --git a/kernel/log.h b/kernel/log.h
-index 7599390..30f2a64 100644
+index 3e1faca..82e27d0 100644
--- a/kernel/log.h
+++ b/kernel/log.h
-@@ -121,7 +121,7 @@ static inline void log_assert_worker(bool cond, const char *expr, const char *fi
+@@ -165,7 +165,7 @@ static inline void log_assert_worker(bool cond, const char *expr, const char *fi
// This is the magic behind the code coverage counters
// ---------------------------------------------------
@@ -100,10 +100,10 @@ index 7599390..30f2a64 100644
#define cover(_id) do { \
static CoverData __d __attribute__((section("yosys_cover_list"), aligned(1), used)) = { __FILE__, __FUNCTION__, _id, __LINE__, 0 }; \
diff --git a/kernel/yosys.cc b/kernel/yosys.cc
-index 450e4e4..68ba3e6 100644
+index 69a1417..791d40e 100644
--- a/kernel/yosys.cc
+++ b/kernel/yosys.cc
-@@ -79,7 +79,7 @@ std::vector<void*> memhasher_store;
+@@ -89,7 +89,7 @@ std::vector<void*> memhasher_store;
void memhasher_on()
{
@@ -112,7 +112,7 @@ index 450e4e4..68ba3e6 100644
memhasher_rng += time(NULL) << 16 ^ getpid();
#endif
memhasher_store.resize(0x10000);
-@@ -679,7 +679,7 @@ struct TclPass : public Pass {
+@@ -737,7 +737,7 @@ struct TclPass : public Pass {
} TclPass;
#endif
@@ -135,10 +135,10 @@ index 1921a1d..efbfb08 100644
#include <stdlib.h>
diff --git a/passes/cmds/cover.cc b/passes/cmds/cover.cc
-index 0ec7476..5f0042a 100644
+index 1128116..0d137ca 100644
--- a/passes/cmds/cover.cc
+++ b/passes/cmds/cover.cc
-@@ -128,7 +128,7 @@ struct CoverPass : public Pass {
+@@ -130,7 +130,7 @@ struct CoverPass : public Pass {
log("\n");
}