summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2015-08-16 21:15:07 +0200
committerClifford Wolf <clifford@clifford.at>2015-08-16 21:15:07 +0200
commitaedcfd6fd3ea99d9d418b81d376590bdb00c2c5c (patch)
treeaa1fc8ef23397a367a08fcb204b91b12b1a89799 /Makefile
parentd5b1a90b33458616c9c002062330c5420335ed31 (diff)
Fixed Makefile rules for generated share files
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 30087380..0aff340b 100644
--- a/Makefile
+++ b/Makefile
@@ -195,6 +195,13 @@ $(subst //,/,$(1)/$(notdir $(2))): $(2)
$$(Q) cp "$(YOSYS_SRC)"/$(2) $(subst //,/,$(1)/$(notdir $(2)))
endef
+define add_gen_share_file
+EXTRA_TARGETS += $(subst //,/,$(1)/$(notdir $(2)))
+$(subst //,/,$(1)/$(notdir $(2))): $(2)
+ $$(P) mkdir -p $(1)
+ $$(Q) cp $(2) $(subst //,/,$(1)/$(notdir $(2)))
+endef
+
define add_include_file
$(eval $(call add_share_file,$(dir share/include/$(1)),$(1)))
endef