summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2013-03-07 17:34:40 +0100
committerClifford Wolf <clifford@clifford.at>2013-03-07 17:34:40 +0100
commitb070b821876c2d277514f4ac6b0d62d0e26a500e (patch)
tree09f261948c986bd7f89a62b5df51bd9f35715086 /Makefile
parent8960bba9b58a6dc489a924b8033d63a530119a4e (diff)
Cleanups and improvements in Makefile
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile19
1 files changed, 17 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index f8ba724c..b20d1771 100644
--- a/Makefile
+++ b/Makefile
@@ -62,7 +62,7 @@ install: yosys
clean:
rm -f $(OBJS) $(GENFILES) $(TARGETS)
- rm -f bigint/*.d frontends/*/*.d passes/*/*.d backends/*/*.d kernel/*.d
+ rm -f libs/*/*.d frontends/*/*.d passes/*/*.d backends/*/*.d kernel/*.d
mrproper: clean
git clean -xdf
@@ -74,9 +74,24 @@ qtcreator:
{ echo .; find backends frontends kernel libs passes -type f \( -name '*.h' -o -name '*.hh' \) -printf '%h\n' | sort -u; } > qtcreator.includes
touch qtcreator.config qtcreator.creator
--include bigint/*.d
+config-clean: clean
+ rm -f Makefile.conf
+
+config-clang-debug: clean
+ echo 'CONFIG := clang-debug' > Makefile.conf
+
+config-gcc-debug: clean
+ echo 'CONFIG := gcc-debug' > Makefile.conf
+
+config-release: clean
+ echo 'CONFIG := release' > Makefile.conf
+
+-include libs/*/*.d
-include frontends/*/*.d
-include passes/*/*.d
-include backends/*/*.d
-include kernel/*.d
+.PHONY: all top-all test clean mrproper qtcreator
+.PHONY: config-clean config-clang-debug config-gcc-debug config-release
+