summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2015-08-12 16:54:30 +0200
committerClifford Wolf <clifford@clifford.at>2015-08-12 16:54:30 +0200
commitfc20b1c3d210ff1821d6c56fb0b8c9c6ba625aa5 (patch)
tree45d8c82bb6571634820ed0432c561c47a8d5f08f /Makefile
parente4ef000b703080131f4608f8bdcbe108a9b30b51 (diff)
Fixed "make clean" for out-of-tree builds
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 3fb9c570..6585ca39 100644
--- a/Makefile
+++ b/Makefile
@@ -397,7 +397,7 @@ manual: $(TARGETS) $(EXTRA_TARGETS)
clean:
rm -rf share
- cd manual && bash clean.sh
+ if test -d manual; then cd manual && sh clean.sh; fi
rm -f $(OBJS) $(GENFILES) $(TARGETS) $(EXTRA_TARGETS) $(EXTRA_OBJS)
rm -f kernel/version_*.o kernel/version_*.cc abc/abc-[0-9a-f]*
rm -f libs/*/*.d frontends/*/*.d passes/*/*.d backends/*/*.d kernel/*.d techlibs/*/*.d