summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorFabio Utzig <utzig@utzig.org>2015-01-08 09:58:24 -0200
committerFabio Utzig <utzig@utzig.org>2015-01-08 09:58:24 -0200
commit0a231f96d79d3eae927bf33571846c98f78eedfd (patch)
treec568f20de24629d332ff2ea5d935ae4a1573e43f /Makefile
parentfff6f00b3c8704473bbb8149c82a2805fb1c32d2 (diff)
Enable use of homebrew's provided bison if available
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 0ac0b7ef..a3aa2a39 100644
--- a/Makefile
+++ b/Makefile
@@ -44,6 +44,8 @@ ifeq (Darwin,$(findstring Darwin,$(shell uname)))
# add homebrew's libffi include and library path
CXXFLAGS += $(shell PKG_CONFIG_PATH=$$(brew list libffi | grep pkgconfig | xargs dirname) pkg-config --silence-errors --cflags libffi)
LDFLAGS += $(shell PKG_CONFIG_PATH=$$(brew list libffi | grep pkgconfig | xargs dirname) pkg-config --silence-errors --libs libffi)
+ # use bison installed by homebrew if available
+ BISON = $(shell (brew list bison | grep -m1 "bin/bison") || echo bison)
SED = gsed
else
LDFLAGS += -rdynamic