summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2015-02-09 16:36:37 +0100
committerClifford Wolf <clifford@clifford.at>2015-02-09 16:36:37 +0100
commit68979d13957825b2d9ec7638f5af057a3c832f89 (patch)
tree6caa17b2dfa675f26be7f12f44e481ef5c336e8f /Makefile
parenta779a09771f7373b8d1e77d7a9182fd3ed9008e5 (diff)
Various changes to release checklist
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index b6cf42cb..7b4707af 100644
--- a/Makefile
+++ b/Makefile
@@ -341,6 +341,9 @@ uninstall:
$(INSTALL_SUDO) rm -vf $(addprefix $(DESTDIR)/bin/,$(notdir $(TARGETS)))
$(INSTALL_SUDO) rm -rvf $(DESTDIR)/share/yosys/
+update-manual: $(TARGETS) $(EXTRA_TARGETS)
+ cd manual && ../yosys -p 'help -write-tex-command-reference-manual'
+
manual: $(TARGETS) $(EXTRA_TARGETS)
cd manual && bash appnotes.sh
cd manual && bash presentation.sh