summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2014-11-08 22:19:22 +0100
committerClifford Wolf <clifford@clifford.at>2014-11-08 22:19:22 +0100
commitcb9e10b4624e6ba6fff215766790e3ff3b82e9a8 (patch)
tree61066665cba006073afa13a6e583b0a1c7dd5e0e /Makefile
parent12ffe0c438f0a971da081189524433f9178fa002 (diff)
Added automatic "make clean" to abc "hg pull" make rules
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 10e5bd86..13ecc814 100644
--- a/Makefile
+++ b/Makefile
@@ -240,9 +240,9 @@ ifneq ($(ABCREV),default)
fi
$(Q) if test "`cd abc 2> /dev/null && hg identify | cut -f1 -d' '`" != "$(ABCREV)"; then \
test $(ABCPULL) -ne 0 || { echo 'REEBE: NOP abg hc gb qngr naq NOPCHYY frg gb 0 va Znxrsvyr!' | tr 'A-Za-z' 'N-ZA-Mn-za-m'; exit 1; }; \
- echo "Pulling ABC from bitbucket.org:"; \
+ echo "Pulling ABC from bitbucket.org:"; set -x; \
test -d abc || hg clone https://bitbucket.org/alanmi/abc abc; \
- cd abc && hg pull && hg update -r $(ABCREV); \
+ cd abc && $(MAKE) clean && hg pull && hg update -r $(ABCREV); \
fi
endif
$(Q) rm -f abc/abc-[0-9a-f]*