summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2014-08-27 12:13:53 +0200
committerClifford Wolf <clifford@clifford.at>2014-08-27 12:13:53 +0200
commitcfb43383198aeb59e461bc0565a9a178d2ae6f01 (patch)
treeb771a9b1b7b7ff33026cac0f5b1d633980567a36 /Makefile
parent084685f4805e643c4799abcbfe114ab8c1138b72 (diff)
Fixed printing of multi-line Makefile.conf
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index fa42cf7d..49a38726 100644
--- a/Makefile
+++ b/Makefile
@@ -58,8 +58,13 @@ OBJS = kernel/version_$(GIT_REV).o
ABCREV = 4d547a5e065b
ABCPULL = 1
+define newline
+
+
+endef
+
ifneq ($(wildcard Makefile.conf),)
-$(info $(shell sed 's,^,[Makefile.conf] ,' < Makefile.conf))
+$(info $(subst $$--$$,$(newline),$(shell sed 's,^,[Makefile.conf] ,; s,$$,$$--$$,;' < Makefile.conf | tr -d '\n' | sed 's,\$$--\$$$$,,')))
include Makefile.conf
endif