summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2014-08-26 10:11:46 +0200
committerClifford Wolf <clifford@clifford.at>2014-08-26 10:11:46 +0200
commite70480655e8d1326bc4828ccada20e7669fa719f (patch)
tree2260439106d6ac4394af07831da3eaa48f698262 /Makefile
parent672b2c6db1feb252e3fe907f1e24ae273156638a (diff)
Print Makefile.conf as make info message
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 09b2adbc..fa42cf7d 100644
--- a/Makefile
+++ b/Makefile
@@ -58,7 +58,10 @@ OBJS = kernel/version_$(GIT_REV).o
ABCREV = 4d547a5e065b
ABCPULL = 1
--include Makefile.conf
+ifneq ($(wildcard Makefile.conf),)
+$(info $(shell sed 's,^,[Makefile.conf] ,' < Makefile.conf))
+include Makefile.conf
+endif
ifeq ($(CONFIG),clang)
CXX = clang