summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorMartin Schmölzer <mschmoelzer@gmail.com>2015-01-18 16:09:42 +0100
committerMartin Schmölzer <mschmoelzer@gmail.com>2015-01-18 16:20:57 +0100
commit026b94a6f10525be7f3f8d354f4b9889aacef605 (patch)
tree700bf2813155593a4995fddc1f866f180b8f70b4 /Makefile
parent694cc01f1de8e0d7db7c5e03cb93796430c6ca5b (diff)
Add "echo-yosys-ver" and "echo-git-rev" Makefile targets.
These Makefile targets simply echo the corresponding Makefile variable, simplifying package build scripts. Signed-off-by: Martin Schmölzer <mschmoelzer@gmail.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index a1e2cb76..278ad881 100644
--- a/Makefile
+++ b/Makefile
@@ -385,6 +385,12 @@ config-gprof: clean
config-sudo:
echo "INSTALL_SUDO := sudo" >> Makefile.conf
+echo-yosys-ver:
+ @echo "$(YOSYS_VER)"
+
+echo-git-rev:
+ @echo "$(GIT_REV)"
+
-include libs/*/*.d
-include frontends/*/*.d
-include passes/*/*.d