summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2014-07-25 13:15:46 +0200
committerClifford Wolf <clifford@clifford.at>2014-07-25 13:24:26 +0200
commit1834af5e5382de67860f5714746566123c4d6b53 (patch)
tree6c8ed6a485914d3e4e72eae8353e275482c99c0f /Makefile
parent309d64d46a7ca7390ccb27b06ecb78228c8b54f6 (diff)
Added "make vgtest"
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 29c6113f..6dde27a9 100644
--- a/Makefile
+++ b/Makefile
@@ -226,6 +226,11 @@ test: $(TARGETS) $(EXTRA_TARGETS)
cd tests/memories && bash run-test.sh
cd tests/sat && bash run-test.sh
+VALGRIND ?= valgrind --error-exitcode=1 --leak-check=full --show-reachable=yes --errors-for-leak-kinds=all
+
+vgtest: $(TARGETS) $(EXTRA_TARGETS)
+ $(VALGRIND) ./yosys -p 'setattr -mod -unset top; hierarchy; proc; opt; memory -nomap; opt -fine; techmap; opt' $$( ls tests/simple/*.v | grep -v repwhile.v )
+
vloghtb: $(TARGETS) $(EXTRA_TARGETS)
cd tests/vloghtb && bash run-test.sh