summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2014-09-13 17:28:15 +0200
committerClifford Wolf <clifford@clifford.at>2014-09-13 17:28:15 +0200
commit3ae96f85a5528414eee458e8aa992aae90ceba7d (patch)
tree89674dd0647c884ff1129919befbef9cf3e370ba /Makefile
parent44b5bd4b631874e5ed083d5de75f5b87431f935f (diff)
Using pkg-config to find libffi
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index a499157a..3ec89916 100644
--- a/Makefile
+++ b/Makefile
@@ -94,8 +94,8 @@ LDLIBS += -lreadline
endif
ifeq ($(ENABLE_PLUGINS),1)
-CXXFLAGS += -DYOSYS_ENABLE_PLUGINS
-LDLIBS += -lffi -ldl
+CXXFLAGS += -DYOSYS_ENABLE_PLUGINS $(shell pkg-config --silence-errors --cflags libffi)
+LDLIBS += $(shell pkg-config --silence-errors --libs libffi || echo -lffi) -ldl
endif
ifeq ($(ENABLE_TCL),1)