summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2013-12-04 08:31:52 +0100
committerClifford Wolf <clifford@clifford.at>2013-12-04 08:31:52 +0100
commitbb20aceeb39694d089cae7dc7f493976406d4b2d (patch)
tree86f537e0440d04fb7e4839d35544cfbdb11dc58e /Makefile
parent637a12b7e3ddcf998ca020ab2c1eddb4bbd27c8d (diff)
More ABC releated Makefile changes
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index ed079351..2590033a 100644
--- a/Makefile
+++ b/Makefile
@@ -31,7 +31,12 @@ YOSYS_VER := 0.1.0+
GIT_REV := $(shell git rev-parse --short HEAD || echo UNKOWN)
OBJS = kernel/version_$(GIT_REV).o
-# set to 'default' to use abc/ as it is
+# set 'ABC = default' to use abc/ as it is
+#
+# Note: If you do ABC development, make sure that 'abc' in this directory
+# is just a symlink to your actual ABC working directory, as 'make mrproper'
+# will remove the 'abc' directory and you do not want to accidentally
+# delete your work on ABC..
ABCREV = 9241719523f6
ABCPULL = 1
@@ -119,6 +124,10 @@ endif
rm -f abc/abc-[0-9a-f]*
cd abc && $(MAKE) PROG="abc-$(ABCREV)" MSG_PREFIX="YOSYS-ABC: "
+ifeq ($(ABCREV),default)
+.PHONY: abc/abc-$(ABCREV)
+endif
+
yosys-abc: abc/abc-$(ABCREV)
cp abc/abc-$(ABCREV) yosys-abc