summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2014-10-11 10:59:11 +0200
committerClifford Wolf <clifford@clifford.at>2014-10-11 10:59:11 +0200
commite8c66ee36bdbaa9652a4e838cabeff4107f50da1 (patch)
treeb4192f4fbcb23dc02c496ea3932b39ea6d58e992 /Makefile
parent53349fb634e79641a7a728f6d030c5eda0702477 (diff)
Fixed MXE readline support
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 6faeeb4c..6b77d854 100644
--- a/Makefile
+++ b/Makefile
@@ -102,6 +102,9 @@ endif
ifeq ($(ENABLE_READLINE),1)
CXXFLAGS += -DYOSYS_ENABLE_READLINE
LDLIBS += -lreadline
+ifeq ($(CONFIG),mxe)
+LDLIBS += -lpdcurses
+endif
endif
ifeq ($(ENABLE_PLUGINS),1)
@@ -330,7 +333,6 @@ config-mxe: clean
echo 'ENABLE_TCL := 0' >> Makefile.conf
echo 'ENABLE_ABC := 0' >> Makefile.conf
echo 'ENABLE_PLUGINS := 0' >> Makefile.conf
- echo 'ENABLE_READLINE := 0' >> Makefile.conf
config-gprof: clean
echo 'CONFIG := gcc' > Makefile.conf