summaryrefslogtreecommitdiff
path: root/backends/smt2/Makefile.inc
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-08-30 20:46:22 +0200
committerRuben Undheim <ruben.undheim@gmail.com>2018-08-30 20:46:22 +0200
commit78bfe0de96fa5c6a7e53689ef53deaeac1d0a7b8 (patch)
treecc36d8cc573f1e6cc9b15ccc85a66883356cbf5f /backends/smt2/Makefile.inc
parent291bd6d9b3f51ea86c38bbe998c0896ad8b9fed2 (diff)
parent5033b51947a6ef02cb785b5622e993335efa750a (diff)
Merge tag 'upstream/0.7+20180830git0b7a184'
Upstream version 0.7+20180830git0b7a184
Diffstat (limited to 'backends/smt2/Makefile.inc')
-rw-r--r--backends/smt2/Makefile.inc2
1 files changed, 1 insertions, 1 deletions
diff --git a/backends/smt2/Makefile.inc b/backends/smt2/Makefile.inc
index eacda273..dce82f01 100644
--- a/backends/smt2/Makefile.inc
+++ b/backends/smt2/Makefile.inc
@@ -6,7 +6,7 @@ ifneq ($(CONFIG),emcc)
TARGETS += yosys-smtbmc
yosys-smtbmc: backends/smt2/smtbmc.py
- $(P) sed 's|##yosys-sys-path##|sys.path += [os.path.dirname(__file__) + p for p in ["/share/python3", "/../share/yosys/python3"]]|;' < $< > $@.new
+ $(P) sed 's|##yosys-sys-path##|sys.path += [os.path.dirname(os.path.realpath(__file__)) + p for p in ["/share/python3", "/../share/yosys/python3"]]|;' < $< > $@.new
$(Q) chmod +x $@.new
$(Q) mv $@.new $@