summaryrefslogtreecommitdiff
path: root/backends/smt2/Makefile.inc
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2015-10-14 01:31:54 +0200
committerClifford Wolf <clifford@clifford.at>2015-10-14 01:31:54 +0200
commit3c315721525d40c14b4a29daf9983be474374908 (patch)
treea3ca5d9ec461a87773308c1139b2b81f8097c1a0 /backends/smt2/Makefile.inc
parentd7de0f4bd1d24842eec895af22396376bce128fc (diff)
Added yosys-smtbmc copyright
Diffstat (limited to 'backends/smt2/Makefile.inc')
-rw-r--r--backends/smt2/Makefile.inc2
1 files changed, 1 insertions, 1 deletions
diff --git a/backends/smt2/Makefile.inc b/backends/smt2/Makefile.inc
index be52ca89..eacda273 100644
--- a/backends/smt2/Makefile.inc
+++ b/backends/smt2/Makefile.inc
@@ -6,7 +6,7 @@ ifneq ($(CONFIG),emcc)
TARGETS += yosys-smtbmc
yosys-smtbmc: backends/smt2/smtbmc.py
- $(P) sed '3 { p; s|.*|sys.path += [os.path.dirname(__file__) + p for p in ["/share/python3", "/../share/yosys/python3"]]|; }' < $< > $@.new
+ $(P) sed 's|##yosys-sys-path##|sys.path += [os.path.dirname(__file__) + p for p in ["/share/python3", "/../share/yosys/python3"]]|;' < $< > $@.new
$(Q) chmod +x $@.new
$(Q) mv $@.new $@