summaryrefslogtreecommitdiff
path: root/backends
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-07-27 18:46:13 +0000
committerRuben Undheim <ruben.undheim@gmail.com>2019-10-20 11:01:06 +0200
commit5dd425f139ebb439ae8e96d4ce8b212046431463 (patch)
treeeaea4f80ab6eafa5f4b0a26a83e30a86799d8d3a /backends
parent99d537f08eef521e5df46a4287b313991ae591c0 (diff)
Fix adding of sys.path in yosys-smtbmc
Gbp-Pq: Name 0010-Fix-adding-of-sys.path-in-yosys-smtbmc.patch
Diffstat (limited to 'backends')
-rw-r--r--backends/smt2/Makefile.inc2
1 files changed, 1 insertions, 1 deletions
diff --git a/backends/smt2/Makefile.inc b/backends/smt2/Makefile.inc
index 92941d4c..2c0b7c69 100644
--- a/backends/smt2/Makefile.inc
+++ b/backends/smt2/Makefile.inc
@@ -22,7 +22,7 @@ else
TARGETS += yosys-smtbmc
yosys-smtbmc: backends/smt2/smtbmc.py
- $(P) sed 's|##yosys-sys-path##|sys.path += [os.path.dirname(os.path.realpath(__file__)) + p for p in ["/share/python3", "/../share/yosys/python3"]]|;' < $< > $@.new
+ $(P) sed 's|##yosys-sys-path##|sys.path += ["/usr/share/yosys"]|;' < $< > $@.new
$(Q) chmod +x $@.new
$(Q) mv $@.new $@
endif