summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2016-05-03 19:14:02 +0000
committerRuben Undheim <ruben.undheim@gmail.com>2016-05-03 19:51:31 +0000
commit4d22fa0ba20643584b7db315b1b4d25028182ae2 (patch)
tree4cc1c3efada402f6777e511dd90366e9c9352b4a /debian
parented5b83a48a4d55a5d91bea433ea19edb14d2573f (diff)
Fix FTBFS
Move PDFs to /usr/share/doc/yosys
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog12
-rw-r--r--debian/patches/fix_ftbfs_cannot_find_infinite.patch59
-rw-r--r--debian/patches/series1
-rw-r--r--debian/yosys-doc.doc-base2
-rw-r--r--debian/yosys-doc.docs2
-rw-r--r--debian/yosys-doc.install2
6 files changed, 73 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index a417a8ef..4f995b65 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,16 @@
yosys (0.6-5) UNRELEASED; urgency=medium
- * debian/patches: Add a bugfix patch from upstream's development branch.
+ [ Sebastian Kuzminsky ]
+ * debian/patches/fixup-initalization.patch:
+ - Add a bugfix patch from upstream's development branch.
+
+ [ Ruben Undheim ]
+ * debian/patches/fix_ftbfs_cannot_find_infinite.patch:
+ - Fixes FTBFS due to std::isfinite not found. (Closes: #822408)
+ * Move PDFs in yosys-doc to /usr/share/doc/yosys in order to adhere to
+ Debian Policy 12.3.
- -- Sebastian Kuzminsky <seb@highlab.com> Fri, 22 Apr 2016 10:37:14 -0600
+ -- Ruben Undheim <ruben.undheim@gmail.com> Tue, 03 May 2016 19:18:03 +0000
yosys (0.6-4) unstable; urgency=medium
diff --git a/debian/patches/fix_ftbfs_cannot_find_infinite.patch b/debian/patches/fix_ftbfs_cannot_find_infinite.patch
new file mode 100644
index 00000000..97b915b5
--- /dev/null
+++ b/debian/patches/fix_ftbfs_cannot_find_infinite.patch
@@ -0,0 +1,59 @@
+Description: This patch fixes an FTBFS due to std::infinite not
+ available
+Author: Ruben Undheim <ruben.undheim@gmail.com>
+Bug-Debian: https://bugs.debian.org/822408
+
+Index: yosys/frontends/ast/ast.cc
+===================================================================
+--- yosys.orig/frontends/ast/ast.cc
++++ yosys/frontends/ast/ast.cc
+@@ -857,11 +857,7 @@ RTLIL::Const AstNode::realAsConst(int wi
+ {
+ double v = round(realvalue);
+ RTLIL::Const result;
+-#ifdef EMSCRIPTEN
+ if (!isfinite(v)) {
+-#else
+- if (!std::isfinite(v)) {
+-#endif
+ result.bits = std::vector<RTLIL::State>(width, RTLIL::State::Sx);
+ } else {
+ bool is_negative = v < 0;
+Index: yosys/passes/cmds/qwp.cc
+===================================================================
+--- yosys.orig/passes/cmds/qwp.cc
++++ yosys/passes/cmds/qwp.cc
+@@ -19,6 +19,7 @@
+
+ #include "kernel/yosys.h"
+ #include "kernel/sigtools.h"
++#include <math.h>
+
+ #undef LOG_MATRICES
+ #undef PYPLOT_EDGES
+@@ -341,7 +342,7 @@ struct QwpWorker
+ double c = alt_mode ? alt_midpos : midpos;
+ double r = alt_mode ? alt_radius : radius;
+
+- if (std::isfinite(v)) {
++ if (isfinite(v)) {
+ v = min(v, c+r);
+ v = max(v, c-r);
+ } else {
+@@ -523,14 +524,14 @@ struct QwpWorker
+ double rel_pos = node.pos - median;
+ if (rel_pos < 0) {
+ node.pos = midpos + left_scale*rel_pos;
+- if (std::isfinite(node.pos)) {
++ if (isfinite(node.pos)) {
+ node.pos = min(node.pos, midpos);
+ node.pos = max(node.pos, midpos - radius);
+ } else
+ node.pos = midpos - radius/2;
+ } else {
+ node.pos = midpos + right_scale*rel_pos;
+- if (std::isfinite(node.pos)) {
++ if (isfinite(node.pos)) {
+ node.pos = max(node.pos, midpos);
+ node.pos = min(node.pos, midpos + radius);
+ } else
diff --git a/debian/patches/series b/debian/patches/series
index 11e4a281..b4ac4ab0 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -8,3 +8,4 @@ manual-build.patch
add-missing-headers.patch
kfreebsd-support.patch
fixup-initalization.patch
+fix_ftbfs_cannot_find_infinite.patch
diff --git a/debian/yosys-doc.doc-base b/debian/yosys-doc.doc-base
index 6df1aa08..3a2a29a8 100644
--- a/debian/yosys-doc.doc-base
+++ b/debian/yosys-doc.doc-base
@@ -6,4 +6,4 @@ Abstract: This manual describes what yosys is and how it can be used to
Section: Science/Electronics
Format: PDF
-Files: /usr/share/doc/yosys-doc/*.pdf
+Files: /usr/share/doc/yosys/*.pdf
diff --git a/debian/yosys-doc.docs b/debian/yosys-doc.docs
deleted file mode 100644
index 5456b0c4..00000000
--- a/debian/yosys-doc.docs
+++ /dev/null
@@ -1,2 +0,0 @@
-manual/presentation.pdf
-manual/manual.pdf
diff --git a/debian/yosys-doc.install b/debian/yosys-doc.install
new file mode 100644
index 00000000..74dba8bf
--- /dev/null
+++ b/debian/yosys-doc.install
@@ -0,0 +1,2 @@
+manual/presentation.pdf usr/share/doc/yosys
+manual/manual.pdf usr/share/doc/yosys