summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-07-27 18:46:56 +0000
committerRuben Undheim <ruben.undheim@gmail.com>2018-07-27 18:46:56 +0000
commite25ca7b2218e5c6393403e439cc5b47345e2acc6 (patch)
tree02cc6bc744bcfedc20c3daf7f609f299617c84ca /debian
parent3f6dadd9a0ca7f47e6f6a31392ed7a25b4727337 (diff)
Patch the issue with finding module smtio
Diffstat (limited to 'debian')
-rw-r--r--debian/patches/0010-Fix-adding-of-sys.path-in-yosys-smtbmc.patch21
-rw-r--r--debian/patches/series1
2 files changed, 22 insertions, 0 deletions
diff --git a/debian/patches/0010-Fix-adding-of-sys.path-in-yosys-smtbmc.patch b/debian/patches/0010-Fix-adding-of-sys.path-in-yosys-smtbmc.patch
new file mode 100644
index 00000000..9ffefdbc
--- /dev/null
+++ b/debian/patches/0010-Fix-adding-of-sys.path-in-yosys-smtbmc.patch
@@ -0,0 +1,21 @@
+From: Ruben Undheim <ruben.undheim@gmail.com>
+Date: Fri, 27 Jul 2018 18:46:13 +0000
+Subject: Fix adding of sys.path in yosys-smtbmc
+
+---
+ backends/smt2/Makefile.inc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/backends/smt2/Makefile.inc b/backends/smt2/Makefile.inc
+index eacda27..f98e610 100644
+--- a/backends/smt2/Makefile.inc
++++ b/backends/smt2/Makefile.inc
+@@ -6,7 +6,7 @@ ifneq ($(CONFIG),emcc)
+ TARGETS += yosys-smtbmc
+
+ yosys-smtbmc: backends/smt2/smtbmc.py
+- $(P) sed 's|##yosys-sys-path##|sys.path += [os.path.dirname(__file__) + p for p in ["/share/python3", "/../share/yosys/python3"]]|;' < $< > $@.new
++ $(P) sed 's|##yosys-sys-path##|sys.path += ["/usr/share/yosys"]|;' < $< > $@.new
+ $(Q) chmod +x $@.new
+ $(Q) mv $@.new $@
+
diff --git a/debian/patches/series b/debian/patches/series
index 734cbdfe..57796885 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -7,3 +7,4 @@ kfreebsd-support.patch
0007-Disable-pretty-build.patch
0009-Some-spelling-errors-fixed.patch
0010-Fix-reproducibility-of-PDF-documents-in-yosys-doc.patch
+0010-Fix-adding-of-sys.path-in-yosys-smtbmc.patch