summaryrefslogtreecommitdiff
path: root/passes/techmap/Makefile.inc
diff options
context:
space:
mode:
authorJohann Glaser <Johann.Glaser@gmx.at>2013-03-17 22:02:46 +0100
committerClifford Wolf <clifford@clifford.at>2013-03-18 07:28:31 +0100
commit3b8ebd694d95ed178b94af538f2694534b86a833 (patch)
tree8072da533101eeb91cf3904063f4aa6b28b2129d /passes/techmap/Makefile.inc
parentcd8008bda01091b7da63d4a2c7b2fe3749ee9f36 (diff)
add header to autogenerated file on its origin
Diffstat (limited to 'passes/techmap/Makefile.inc')
-rw-r--r--passes/techmap/Makefile.inc4
1 files changed, 3 insertions, 1 deletions
diff --git a/passes/techmap/Makefile.inc b/passes/techmap/Makefile.inc
index ba365525..2e90215e 100644
--- a/passes/techmap/Makefile.inc
+++ b/passes/techmap/Makefile.inc
@@ -3,8 +3,10 @@ GENFILES += passes/techmap/stdcells.inc
OBJS += passes/techmap/techmap.o
passes/techmap/stdcells.inc: techlibs/stdcells.v
+ echo -n "// autogenerated from $< on " > $@.new
+ LANG=C date >> $@.new
od -v -td1 -w1 $< | awk 'BEGIN { print "static char stdcells_code[] = {"; } $$2 != "" { print $$2 ","; } \
- END { print 0 "};"; }' | fmt > $@.new
+ END { print 0 "};"; }' | fmt >> $@.new
mv $@.new $@
passes/techmap/techmap.o: passes/techmap/stdcells.inc