summaryrefslogtreecommitdiff
path: root/passes/techmap/Makefile.inc
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2014-07-24 17:15:01 +0200
committerClifford Wolf <clifford@clifford.at>2014-07-24 17:15:01 +0200
commitb17d6531c833f9064c5888c694aa24e8a395b72a (patch)
treef1cd2bd0044f938cd9371a63b5650df0e0fc20a7 /passes/techmap/Makefile.inc
parent2f54345cff3aea768bb89754654127a3b0ee58e9 (diff)
Added "make PRETTY=1"
Diffstat (limited to 'passes/techmap/Makefile.inc')
-rw-r--r--passes/techmap/Makefile.inc12
1 files changed, 6 insertions, 6 deletions
diff --git a/passes/techmap/Makefile.inc b/passes/techmap/Makefile.inc
index 85d580ce..c901da1c 100644
--- a/passes/techmap/Makefile.inc
+++ b/passes/techmap/Makefile.inc
@@ -10,11 +10,11 @@ OBJS += passes/techmap/extract.o
GENFILES += passes/techmap/stdcells.inc
passes/techmap/stdcells.inc: techlibs/common/stdcells.v
- echo "// autogenerated from $<" > $@.new
- echo "static char stdcells_code[] = {" >> $@.new
- od -v -td1 -An $< | $(SED) -e 's/[0-9][0-9]*/&,/g' >> $@.new
- echo "0};" >> $@.new
- mv $@.new $@
+ $(P) echo "// autogenerated from $<" > $@.new
+ $(Q) echo "static char stdcells_code[] = {" >> $@.new
+ $(Q) od -v -td1 -An $< | $(SED) -e 's/[0-9][0-9]*/&,/g' >> $@.new
+ $(Q) echo "0};" >> $@.new
+ $(Q) mv $@.new $@
passes/techmap/techmap.o: passes/techmap/stdcells.inc
@@ -22,5 +22,5 @@ TARGETS += yosys-filterlib
GENFILES += passes/techmap/filterlib.o
yosys-filterlib: passes/techmap/filterlib.o
- $(CXX) -o yosys-filterlib $(LDFLAGS) $^ $(LDLIBS)
+ $(P) $(CXX) -o yosys-filterlib $(LDFLAGS) $^ $(LDLIBS)