summaryrefslogtreecommitdiff
path: root/passes/techmap
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2015-08-13 09:52:06 +0200
committerClifford Wolf <clifford@clifford.at>2015-08-13 09:52:06 +0200
commit80910d13a610886f4430fbd991ada78b2e586ada (patch)
treec582d1b1394600030c8bd88a8ec4a3b25178fa1f /passes/techmap
parentc699d7c6145f978b1864c2be25d9f0607099a3e5 (diff)
parent698357dd9a17365566f4db2662e9ce9fea7594c4 (diff)
Merge branch 'master' of github.com:cliffordwolf/yosys
Diffstat (limited to 'passes/techmap')
-rw-r--r--passes/techmap/Makefile.inc2
1 files changed, 2 insertions, 0 deletions
diff --git a/passes/techmap/Makefile.inc b/passes/techmap/Makefile.inc
index e39d5c5c..f1c987cc 100644
--- a/passes/techmap/Makefile.inc
+++ b/passes/techmap/Makefile.inc
@@ -24,6 +24,7 @@ endif
GENFILES += passes/techmap/techmap.inc
passes/techmap/techmap.inc: techlibs/common/techmap.v
+ $(Q) mkdir -p $(dir $@)
$(P) echo "// autogenerated from $<" > $@.new
$(Q) echo "static char stdcells_code[] = {" >> $@.new
$(Q) od -v -td1 -An $< | $(SED) -e 's/[0-9][0-9]*/&,/g' >> $@.new
@@ -37,6 +38,7 @@ TARGETS += yosys-filterlib$(EXE)
EXTRA_OBJS += passes/techmap/filterlib.o
yosys-filterlib$(EXE): passes/techmap/filterlib.o
+ $(Q) mkdir -p $(dir $@)
$(P) $(CXX) -o yosys-filterlib$(EXE) $(LDFLAGS) $^ $(LDLIBS)
endif