summaryrefslogtreecommitdiff
path: root/passes/techmap
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2015-08-12 15:04:44 +0200
committerClifford Wolf <clifford@clifford.at>2015-08-12 15:04:44 +0200
commite4ef000b703080131f4608f8bdcbe108a9b30b51 (patch)
treea9d2afea207bb61ceaa675326c0ea03aec7cd8d9 /passes/techmap
parentc43f38c81be830469eb1536c073c519b25e18f4e (diff)
Adjust makefiles to work with out-of-tree builds
This is based on work done by Larry Doolittle
Diffstat (limited to 'passes/techmap')
-rw-r--r--passes/techmap/Makefile.inc2
1 files changed, 2 insertions, 0 deletions
diff --git a/passes/techmap/Makefile.inc b/passes/techmap/Makefile.inc
index e39d5c5c..f1c987cc 100644
--- a/passes/techmap/Makefile.inc
+++ b/passes/techmap/Makefile.inc
@@ -24,6 +24,7 @@ endif
GENFILES += passes/techmap/techmap.inc
passes/techmap/techmap.inc: techlibs/common/techmap.v
+ $(Q) mkdir -p $(dir $@)
$(P) echo "// autogenerated from $<" > $@.new
$(Q) echo "static char stdcells_code[] = {" >> $@.new
$(Q) od -v -td1 -An $< | $(SED) -e 's/[0-9][0-9]*/&,/g' >> $@.new
@@ -37,6 +38,7 @@ TARGETS += yosys-filterlib$(EXE)
EXTRA_OBJS += passes/techmap/filterlib.o
yosys-filterlib$(EXE): passes/techmap/filterlib.o
+ $(Q) mkdir -p $(dir $@)
$(P) $(CXX) -o yosys-filterlib$(EXE) $(LDFLAGS) $^ $(LDLIBS)
endif