summaryrefslogtreecommitdiff
path: root/techlibs/common/Makefile.inc
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2015-01-08 00:23:18 +0100
committerClifford Wolf <clifford@clifford.at>2015-01-08 00:23:18 +0100
commit1d96277f5d4c615ca4018d9a6e867c980db3b73a (patch)
tree39f016658d8f2d7f23e6a14f63ca6889e52370a5 /techlibs/common/Makefile.inc
parent38dfc5c580c8ba418783ec8cbee1a78c7cd5f788 (diff)
Added add_share_file Makefile macro
Diffstat (limited to 'techlibs/common/Makefile.inc')
-rw-r--r--techlibs/common/Makefile.inc31
1 files changed, 6 insertions, 25 deletions
diff --git a/techlibs/common/Makefile.inc b/techlibs/common/Makefile.inc
index 0607ca1a..dc1e0ef6 100644
--- a/techlibs/common/Makefile.inc
+++ b/techlibs/common/Makefile.inc
@@ -9,29 +9,10 @@ techlibs/common/blackbox.v: techlibs/common/blackbox.sed techlibs/common/simlib.
$(P) cat techlibs/common/simlib.v techlibs/common/simcells.v | $(SED) -rf techlibs/common/blackbox.sed > techlibs/common/blackbox.v.new
$(Q) mv techlibs/common/blackbox.v.new techlibs/common/blackbox.v
-EXTRA_TARGETS += share/simlib.v share/simcells.v share/techmap.v share/blackbox.v share/pmux2mux.v share/adff2dff.v
-
-share/simlib.v: techlibs/common/simlib.v
- $(P) mkdir -p share
- $(Q) cp techlibs/common/simlib.v share/simlib.v
-
-share/simcells.v: techlibs/common/simcells.v
- $(P) mkdir -p share
- $(Q) cp techlibs/common/simcells.v share/simcells.v
-
-share/techmap.v: techlibs/common/techmap.v
- $(P) mkdir -p share
- $(Q) cp techlibs/common/techmap.v share/techmap.v
-
-share/blackbox.v: techlibs/common/blackbox.v
- $(P) mkdir -p share
- $(Q) cp techlibs/common/blackbox.v share/blackbox.v
-
-share/pmux2mux.v: techlibs/common/pmux2mux.v
- $(P) mkdir -p share
- $(Q) cp techlibs/common/pmux2mux.v share/pmux2mux.v
-
-share/adff2dff.v: techlibs/common/adff2dff.v
- $(P) mkdir -p share
- $(Q) cp techlibs/common/adff2dff.v share/adff2dff.v
+$(eval $(call add_share_file,share,techlibs/common/simlib.v))
+$(eval $(call add_share_file,share,techlibs/common/simcells.v))
+$(eval $(call add_share_file,share,techlibs/common/techmap.v))
+$(eval $(call add_share_file,share,techlibs/common/blackbox.v))
+$(eval $(call add_share_file,share,techlibs/common/pmux2mux.v))
+$(eval $(call add_share_file,share,techlibs/common/adff2dff.v))