summaryrefslogtreecommitdiff
path: root/techlibs/common
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2015-08-12 15:04:44 +0200
committerClifford Wolf <clifford@clifford.at>2015-08-12 15:04:44 +0200
commite4ef000b703080131f4608f8bdcbe108a9b30b51 (patch)
treea9d2afea207bb61ceaa675326c0ea03aec7cd8d9 /techlibs/common
parentc43f38c81be830469eb1536c073c519b25e18f4e (diff)
Adjust makefiles to work with out-of-tree builds
This is based on work done by Larry Doolittle
Diffstat (limited to 'techlibs/common')
-rw-r--r--techlibs/common/Makefile.inc7
-rw-r--r--techlibs/common/blackbox.sed5
2 files changed, 0 insertions, 12 deletions
diff --git a/techlibs/common/Makefile.inc b/techlibs/common/Makefile.inc
index d2ce61cf..f222a028 100644
--- a/techlibs/common/Makefile.inc
+++ b/techlibs/common/Makefile.inc
@@ -3,16 +3,9 @@ ifneq ($(SMALL),1)
OBJS += techlibs/common/synth.o
endif
-EXTRA_TARGETS += techlibs/common/blackbox.v
-
-techlibs/common/blackbox.v: techlibs/common/blackbox.sed techlibs/common/simlib.v techlibs/common/simcells.v
- $(P) cat techlibs/common/simlib.v techlibs/common/simcells.v | $(SED) -rf techlibs/common/blackbox.sed > techlibs/common/blackbox.v.new
- $(Q) mv techlibs/common/blackbox.v.new techlibs/common/blackbox.v
-
$(eval $(call add_share_file,share,techlibs/common/simlib.v))
$(eval $(call add_share_file,share,techlibs/common/simcells.v))
$(eval $(call add_share_file,share,techlibs/common/techmap.v))
-$(eval $(call add_share_file,share,techlibs/common/blackbox.v))
$(eval $(call add_share_file,share,techlibs/common/pmux2mux.v))
$(eval $(call add_share_file,share,techlibs/common/adff2dff.v))
$(eval $(call add_share_file,share,techlibs/common/cells.lib))
diff --git a/techlibs/common/blackbox.sed b/techlibs/common/blackbox.sed
deleted file mode 100644
index db890034..00000000
--- a/techlibs/common/blackbox.sed
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sed -r
-/^(wire|assign|reg|event|integer|localparam|\/\/|[\/ ]\*| *$|`)/ d;
-/^(genvar|generate|always|initial|task|function)/,/^end/ d;
-/^endmodule/ s/$/\n/;
-s/ reg / /;