summaryrefslogtreecommitdiff
path: root/techlibs
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2015-08-22 09:59:25 +0200
committerClifford Wolf <clifford@clifford.at>2015-08-22 09:59:33 +0200
commitc475deec6c69d509ac828cca437e2b9502f7b0c3 (patch)
tree6a15b902569999ced894daa3eea505c3dc93d58f /techlibs
parentf40d1b78b629dfebff7598e04b8470e6942f8f58 (diff)
Switched to Python 3
Diffstat (limited to 'techlibs')
-rw-r--r--techlibs/ice40/Makefile.inc2
-rw-r--r--techlibs/ice40/brams_init.py5
-rw-r--r--techlibs/xilinx/Makefile.inc2
-rw-r--r--techlibs/xilinx/brams_init.py5
4 files changed, 4 insertions, 10 deletions
diff --git a/techlibs/ice40/Makefile.inc b/techlibs/ice40/Makefile.inc
index ed495519..63d6086a 100644
--- a/techlibs/ice40/Makefile.inc
+++ b/techlibs/ice40/Makefile.inc
@@ -12,7 +12,7 @@ EXTRA_OBJS += techlibs/ice40/brams_init.mk
techlibs/ice40/brams_init.mk: techlibs/ice40/brams_init.py
$(Q) mkdir -p techlibs/ice40
- $(P) python $<
+ $(P) python3 $<
$(Q) touch techlibs/ice40/brams_init.mk
techlibs/ice40/brams_init1.vh: techlibs/ice40/brams_init.mk
diff --git a/techlibs/ice40/brams_init.py b/techlibs/ice40/brams_init.py
index 93eb9846..4a148511 100644
--- a/techlibs/ice40/brams_init.py
+++ b/techlibs/ice40/brams_init.py
@@ -1,7 +1,4 @@
-#!/usr/bin/python
-
-from __future__ import division
-from __future__ import print_function
+#!/usr/bin/env python3
def write_init_vh(filename, initbits):
with open(filename, "w") as f:
diff --git a/techlibs/xilinx/Makefile.inc b/techlibs/xilinx/Makefile.inc
index cca41f91..ccf88ec7 100644
--- a/techlibs/xilinx/Makefile.inc
+++ b/techlibs/xilinx/Makefile.inc
@@ -11,7 +11,7 @@ EXTRA_OBJS += techlibs/xilinx/brams_init.mk
techlibs/xilinx/brams_init.mk: techlibs/xilinx/brams_init.py
$(Q) mkdir -p techlibs/xilinx
- $(P) python $<
+ $(P) python3 $<
$(Q) touch $@
techlibs/xilinx/brams_init_36.vh: techlibs/xilinx/brams_init.mk
diff --git a/techlibs/xilinx/brams_init.py b/techlibs/xilinx/brams_init.py
index eac829dd..e787b1f7 100644
--- a/techlibs/xilinx/brams_init.py
+++ b/techlibs/xilinx/brams_init.py
@@ -1,7 +1,4 @@
-#!/usr/bin/python
-
-from __future__ import division
-from __future__ import print_function
+#!/usr/bin/env python3
with open("techlibs/xilinx/brams_init_18.vh", "w") as f:
for i in range(8):