summaryrefslogtreecommitdiff
path: root/tests/xsthammer/Makefile
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2013-06-26 12:34:06 +0200
committerClifford Wolf <clifford@clifford.at>2013-06-26 12:34:06 +0200
commita5fe2565b72c3e80f981a9694072233876bf7c9a (patch)
tree9b802db838c9ba52dc90ca3a853df68d22981be9 /tests/xsthammer/Makefile
parent101491132fbd617b0a0819045cc7b5d35395706d (diff)
Added vivado support to xsthammer
Diffstat (limited to 'tests/xsthammer/Makefile')
-rw-r--r--tests/xsthammer/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/tests/xsthammer/Makefile b/tests/xsthammer/Makefile
index ab7aebdc..55d94d45 100644
--- a/tests/xsthammer/Makefile
+++ b/tests/xsthammer/Makefile
@@ -3,12 +3,20 @@ include generate.lst
test: $(TARGETS)
+vivado: $(addprefix check_vivado/,$(notdir $(TARGETS)))
+
check/%.log: rtl/%.v xst/%.v
bash run-check.sh $(notdir $(basename $<))
+check_vivado/%.log: rtl/%.v vivado/%.v
+ bash run-check.sh -vivado $(notdir $(basename $<))
+
xst/%.v: rtl/%.v
bash run-xst.sh $(notdir $(basename $<))
+vivado/%.v: rtl/%.v
+ bash run-vivado.sh $(notdir $(basename $<))
+
generate.lst: generate.cc
clang -Wall -o generate generate.cc -lstdc++
./generate
@@ -23,6 +31,6 @@ clean:
mrproper: clean
rm -rf rtl xst check
-.PHONY: test check_xl_cells clean mrproper
+.PHONY: test vivado check_xl_cells clean mrproper
.PRECIOUS: check/%.log xst/%.v rtl/%.v generate.lst