summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/patches/add-missing-headers.patch14
-rw-r--r--debian/patches/series1
2 files changed, 15 insertions, 0 deletions
diff --git a/debian/patches/add-missing-headers.patch b/debian/patches/add-missing-headers.patch
new file mode 100644
index 00000000..42f5f0d8
--- /dev/null
+++ b/debian/patches/add-missing-headers.patch
@@ -0,0 +1,14 @@
+Description: Include all headers needed to build the yosys plugins.
+Author: Sebastian Kuzminsky <seb@highlab.com>
+Index: yosys/Makefile
+===================================================================
+--- yosys.orig/Makefile 2016-03-23 16:03:43.938560251 -0600
++++ yosys/Makefile 2016-03-23 16:04:07.858313544 -0600
+@@ -269,6 +269,7 @@
+ $(eval $(call add_include_file,libs/sha1/sha1.h))
+ $(eval $(call add_include_file,passes/fsm/fsmdata.h))
+ $(eval $(call add_include_file,backends/ilang/ilang_backend.h))
++$(eval $(call add_include_file,frontends/ast/ast.h))
+
+ OBJS += kernel/driver.o kernel/register.o kernel/rtlil.o kernel/log.o kernel/calc.o kernel/yosys.o kernel/cellaigs.o
+ kernel/log.o: CXXFLAGS += -DYOSYS_SRC='"$(YOSYS_SRC)"'
diff --git a/debian/patches/series b/debian/patches/series
index 9650677b..a73b8046 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -5,3 +5,4 @@
spelling-fixes.patch
switch-to-free-font.patch
manual-build.patch
+add-missing-headers.patch