summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/patches/0013-Let-dpkg-buildpackage-handle-stripping-of-binaries.patch32
-rw-r--r--debian/patches/series1
2 files changed, 33 insertions, 0 deletions
diff --git a/debian/patches/0013-Let-dpkg-buildpackage-handle-stripping-of-binaries.patch b/debian/patches/0013-Let-dpkg-buildpackage-handle-stripping-of-binaries.patch
new file mode 100644
index 00000000..e53c6a28
--- /dev/null
+++ b/debian/patches/0013-Let-dpkg-buildpackage-handle-stripping-of-binaries.patch
@@ -0,0 +1,32 @@
+From: Ruben Undheim <ruben.undheim@gmail.com>
+Date: Wed, 17 Oct 2018 08:40:22 +0200
+Subject: Let dpkg-buildpackage handle stripping of binaries
+
+---
+ Makefile | 4 ----
+ 1 file changed, 4 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 0fe949b..a3f641b 100644
+--- a/Makefile
++++ b/Makefile
+@@ -612,19 +612,15 @@ install: $(TARGETS) $(EXTRA_TARGETS)
+ $(INSTALL_SUDO) mkdir -p $(DESTDIR)$(BINDIR)
+ $(INSTALL_SUDO) cp $(TARGETS) $(DESTDIR)$(BINDIR)
+ ifneq ($(filter yosys,$(TARGETS)),)
+- $(INSTALL_SUDO) $(STRIP) -S $(DESTDIR)$(BINDIR)/yosys
+ endif
+ ifneq ($(filter yosys-abc,$(TARGETS)),)
+- $(INSTALL_SUDO) $(STRIP) $(DESTDIR)$(BINDIR)/yosys-abc
+ endif
+ ifneq ($(filter yosys-filterlib,$(TARGETS)),)
+- $(INSTALL_SUDO) $(STRIP) $(DESTDIR)$(BINDIR)/yosys-filterlib
+ endif
+ $(INSTALL_SUDO) mkdir -p $(DESTDIR)$(DATDIR)
+ $(INSTALL_SUDO) cp -r share/. $(DESTDIR)$(DATDIR)/.
+ ifeq ($(ENABLE_LIBYOSYS),1)
+ $(INSTALL_SUDO) cp libyosys.so $(DESTDIR)$(LIBDIR)
+- $(INSTALL_SUDO) $(STRIP) -S $(DESTDIR)$(LIBDIR)/libyosys.so
+ $(INSTALL_SUDO) ldconfig
+ endif
+
diff --git a/debian/patches/series b/debian/patches/series
index d2a2706f..e7cc6a43 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -9,3 +9,4 @@ kfreebsd-support.patch
0010-Fix-reproducibility-of-PDF-documents-in-yosys-doc.patch
0010-Fix-adding-of-sys.path-in-yosys-smtbmc.patch
0011-Do-not-show-g-build-flags-in-Version-string.patch
+0013-Let-dpkg-buildpackage-handle-stripping-of-binaries.patch