summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile15
-rw-r--r--manual/APPNOTE_011_Design_Investigation/make.sh4
-rwxr-xr-xmanual/appnotes.sh2
-rwxr-xr-xmanual/clean.sh2
4 files changed, 14 insertions, 9 deletions
diff --git a/Makefile b/Makefile
index 0458b70c..697cf69f 100644
--- a/Makefile
+++ b/Makefile
@@ -146,15 +146,17 @@ install: $(TARGETS) $(EXTRA_TARGETS)
$(INSTALL_SUDO) mkdir -p $(DESTDIR)/share/yosys
$(INSTALL_SUDO) cp -r share/. $(DESTDIR)/share/yosys/.
-manual:
+manual: $(TARGETS) $(EXTRA_TARGETS)
+ cd manual && bash appnotes.sh
+ cd manual && bash presentation.sh
cd manual && bash manual.sh
clean:
- rm -rf share
- rm -f $(OBJS) $(GENFILES) $(TARGETS)
- rm -f kernel/version_*.o kernel/version_*.cc abc/abc-[0-9a-f]*
- rm -f libs/*/*.d frontends/*/*.d passes/*/*.d backends/*/*.d kernel/*.d
- cd manual && rm -f *.aux *.bbl *.blg *.idx *.log *.out *.pdf *.toc *.ok
+ rm -rvf share
+ cd manual && bash clean.sh
+ rm -vf $(OBJS) $(GENFILES) $(TARGETS) $(EXTRA_TARGETS)
+ rm -vf kernel/version_*.o kernel/version_*.cc abc/abc-[0-9a-f]*
+ rm -vf libs/*/*.d frontends/*/*.d passes/*/*.d backends/*/*.d kernel/*.d techlibs/*/*.d
test ! -f libs/svgviewer/Makefile || make -C libs/svgviewer distclean
mrproper: clean
@@ -191,6 +193,7 @@ config-sudo:
-include passes/*/*.d
-include backends/*/*.d
-include kernel/*.d
+-include techlibs/*/*.d
.PHONY: all top-all abc test install install-abc manual clean mrproper qtcreator
.PHONY: config-clean config-clang-debug config-gcc-debug config-release
diff --git a/manual/APPNOTE_011_Design_Investigation/make.sh b/manual/APPNOTE_011_Design_Investigation/make.sh
index fa3ca70e..3845dac6 100644
--- a/manual/APPNOTE_011_Design_Investigation/make.sh
+++ b/manual/APPNOTE_011_Design_Investigation/make.sh
@@ -18,6 +18,6 @@ if false; then
sed -i '/^label=/ d;' *.dot
fi
for dot_file in *.dot; do
- pdf_file=${dot_file#.dot}.pdf
- dot -Tpdf -o example_00.pdf example_00.dot
+ pdf_file=${dot_file%.dot}.pdf
+ dot -Tpdf -o $pdf_file $dot_file
done
diff --git a/manual/appnotes.sh b/manual/appnotes.sh
index f816956a..1160af6a 100755
--- a/manual/appnotes.sh
+++ b/manual/appnotes.sh
@@ -11,7 +11,7 @@ do
fi
old_md5=$([ -f $job.aux ] && md5sum < $job.aux || true)
while
- pdflatex -shell-escape -halt-on-error $job.tex
+ pdflatex -shell-escape -halt-on-error $job.tex || exit
new_md5=$(md5sum < $job.aux)
[ "$old_md5" != "$new_md5" ]
do
diff --git a/manual/clean.sh b/manual/clean.sh
new file mode 100755
index 00000000..13554c01
--- /dev/null
+++ b/manual/clean.sh
@@ -0,0 +1,2 @@
+#!/bin/bash
+for f in $( find -name .gitignore ); do sed -re "s,^,find ${f%.gitignore} -name ',; s,$,' | xargs -r rm -vf,;" $f; done | bash -v