summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile7
-rw-r--r--debian/changelog13
-rw-r--r--debian/compat2
-rw-r--r--debian/control4
-rw-r--r--debian/man/.gitignore1
-rw-r--r--debian/patches/0011-Do-not-show-g-build-flags-in-Version-string.patch32
-rw-r--r--debian/patches/series1
-rw-r--r--debian/upstream/metadata6
8 files changed, 60 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index aa66a545..fe746f55 100644
--- a/Makefile
+++ b/Makefile
@@ -370,15 +370,16 @@ libyosys.so: $(filter-out kernel/driver.o,$(OBJS))
$(Q) mkdir -p $(dir $@)
$(P) $(CXX) -o $@ -c $(CPPFLAGS) $(CXXFLAGS) $<
-YOSYS_VER_STR := Yosys $(YOSYS_VER) (git sha1 $(GIT_REV), $(notdir $(CXX)) $(shell \
- $(CXX) --version | tr ' ()' '\n' | grep '^[0-9]' | head -n1) $(filter -f% -m% -O% -DNDEBUG,$(CXXFLAGS)))
+YOSYS_VER_STR := Yosys $(YOSYS_VER) (git sha1 $(GIT_REV))
kernel/version_$(GIT_REV).cc: $(YOSYS_SRC)/Makefile
$(P) rm -f kernel/version_*.o kernel/version_*.d kernel/version_*.cc
$(Q) mkdir -p kernel && echo "namespace Yosys { extern const char *yosys_version_str; const char *yosys_version_str=\"$(YOSYS_VER_STR)\"; }" > kernel/version_$(GIT_REV).cc
+CXXFLAGS_FOR_YOSYS_CONFIG := "$(shell echo $(subst -I. -I"$(YOSYS_SRC)",-I"$(DATDIR)/include",$(CXXFLAGS)) | sed 's/-fdebug-prefix[^ ]\+ //' | sed 's/-ffile-prefix-map[^ ]\+ //')"
+
yosys-config: misc/yosys-config.in
- $(P) $(SED) -e 's#@CXXFLAGS@#$(subst -I. -I"$(YOSYS_SRC)",-I"$(DATDIR)/include",$(CXXFLAGS))#;' \
+ $(P) $(SED) -e 's#@CXXFLAGS@#$(CXXFLAGS_FOR_YOSYS_CONFIG)#;' \
-e 's#@CXX@#$(CXX)#;' -e 's#@LDFLAGS@#$(LDFLAGS)#;' -e 's#@LDLIBS@#$(LDLIBS)#;' \
-e 's#@BINDIR@#$(BINDIR)#;' -e 's#@DATDIR@#$(DATDIR)#;' < $< > yosys-config
$(Q) chmod +x yosys-config
diff --git a/debian/changelog b/debian/changelog
index 334d7903..e49843c0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,16 @@
+yosys (0.7-6) unstable; urgency=medium
+
+ * debian/compat: level 11
+ * debian/control:
+ - debhelper >= 11
+ - Standards version 4.2.0 - no changes
+ * debian/upstream/metadata: Added upstream metadata
+ * d/patches/0011-Do-not-show-g-build-flags-in-Version-string.patch:
+ - some build flags for the g++ version being used were "injected" into
+ the source files for yosys. Remove them
+
+ -- Ruben Undheim <ruben.undheim@gmail.com> Tue, 21 Aug 2018 21:37:46 +0200
+
yosys (0.7-5) unstable; urgency=medium
* debian/patches/0010-Fix-adding-of-sys.path-in-yosys-smtbmc.patch
diff --git a/debian/compat b/debian/compat
index ec635144..b4de3947 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-9
+11
diff --git a/debian/control b/debian/control
index e18ca98a..a9e8b276 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,7 @@ Uploaders: Ruben Undheim <ruben.undheim@gmail.com>,
Sebastian Kuzminsky <seb@highlab.com>
Section: electronics
Priority: optional
-Build-Depends: debhelper (>= 9),
+Build-Depends: debhelper (>= 11),
dh-python,
tcl-dev,
libreadline-dev,
@@ -30,7 +30,7 @@ Build-Depends-Indep:
texlive-bibtex-extra,
lmodern,
graphviz
-Standards-Version: 4.1.5
+Standards-Version: 4.2.0
Vcs-Browser: https://salsa.debian.org/science-team/yosys
Vcs-Git: https://salsa.debian.org/science-team/yosys.git
Homepage: http://www.clifford.at/yosys
diff --git a/debian/man/.gitignore b/debian/man/.gitignore
new file mode 100644
index 00000000..f7e585b8
--- /dev/null
+++ b/debian/man/.gitignore
@@ -0,0 +1 @@
+*.1
diff --git a/debian/patches/0011-Do-not-show-g-build-flags-in-Version-string.patch b/debian/patches/0011-Do-not-show-g-build-flags-in-Version-string.patch
new file mode 100644
index 00000000..4bc67764
--- /dev/null
+++ b/debian/patches/0011-Do-not-show-g-build-flags-in-Version-string.patch
@@ -0,0 +1,32 @@
+From: Ruben Undheim <ruben.undheim@gmail.com>
+Date: Sun, 19 Aug 2018 23:03:51 +0200
+Subject: Do not show g++ build flags in Version string
+
+---
+ Makefile | 7 ++++---
+ 1 file changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index aa66a54..fe746f5 100644
+--- a/Makefile
++++ b/Makefile
+@@ -370,15 +370,16 @@ libyosys.so: $(filter-out kernel/driver.o,$(OBJS))
+ $(Q) mkdir -p $(dir $@)
+ $(P) $(CXX) -o $@ -c $(CPPFLAGS) $(CXXFLAGS) $<
+
+-YOSYS_VER_STR := Yosys $(YOSYS_VER) (git sha1 $(GIT_REV), $(notdir $(CXX)) $(shell \
+- $(CXX) --version | tr ' ()' '\n' | grep '^[0-9]' | head -n1) $(filter -f% -m% -O% -DNDEBUG,$(CXXFLAGS)))
++YOSYS_VER_STR := Yosys $(YOSYS_VER) (git sha1 $(GIT_REV))
+
+ kernel/version_$(GIT_REV).cc: $(YOSYS_SRC)/Makefile
+ $(P) rm -f kernel/version_*.o kernel/version_*.d kernel/version_*.cc
+ $(Q) mkdir -p kernel && echo "namespace Yosys { extern const char *yosys_version_str; const char *yosys_version_str=\"$(YOSYS_VER_STR)\"; }" > kernel/version_$(GIT_REV).cc
+
++CXXFLAGS_FOR_YOSYS_CONFIG := "$(shell echo $(subst -I. -I"$(YOSYS_SRC)",-I"$(DATDIR)/include",$(CXXFLAGS)) | sed 's/-fdebug-prefix[^ ]\+ //' | sed 's/-ffile-prefix-map[^ ]\+ //')"
++
+ yosys-config: misc/yosys-config.in
+- $(P) $(SED) -e 's#@CXXFLAGS@#$(subst -I. -I"$(YOSYS_SRC)",-I"$(DATDIR)/include",$(CXXFLAGS))#;' \
++ $(P) $(SED) -e 's#@CXXFLAGS@#$(CXXFLAGS_FOR_YOSYS_CONFIG)#;' \
+ -e 's#@CXX@#$(CXX)#;' -e 's#@LDFLAGS@#$(LDFLAGS)#;' -e 's#@LDLIBS@#$(LDLIBS)#;' \
+ -e 's#@BINDIR@#$(BINDIR)#;' -e 's#@DATDIR@#$(DATDIR)#;' < $< > yosys-config
+ $(Q) chmod +x yosys-config
diff --git a/debian/patches/series b/debian/patches/series
index 57796885..d2a2706f 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -8,3 +8,4 @@ kfreebsd-support.patch
0009-Some-spelling-errors-fixed.patch
0010-Fix-reproducibility-of-PDF-documents-in-yosys-doc.patch
0010-Fix-adding-of-sys.path-in-yosys-smtbmc.patch
+0011-Do-not-show-g-build-flags-in-Version-string.patch
diff --git a/debian/upstream/metadata b/debian/upstream/metadata
new file mode 100644
index 00000000..a191c0f0
--- /dev/null
+++ b/debian/upstream/metadata
@@ -0,0 +1,6 @@
+---
+Bug-Database: https://github.com/YosysHQ/yosys/issues
+Bug-Submit: https://github.com/YosysHQ/yosys/issues/new
+Name: Yosys
+Repository: https://github.com/YosysHQ/yosys.git
+Repository-Browse: https://github.com/YosysHQ/yosys