summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--kernel/log.cc4
2 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index f408c40f..a43f378e 100644
--- a/Makefile
+++ b/Makefile
@@ -95,7 +95,7 @@ CXXFLAGS := $(filter-out -fPIC,$(CXXFLAGS))
LDFLAGS := $(filter-out -rdynamic,$(LDFLAGS)) -s
LDLIBS := $(filter-out -lrt,$(LDLIBS))
ABCMKARGS += ARCHFLAGS="-DSIZEOF_VOID_P=4 -DSIZEOF_LONG=4 -DSIZEOF_INT=4 -DWIN32_NO_DLL -x c++ -fpermissive -w"
-ABCMKARGS += LIBS="lib/x86/pthreadVC2.lib -s" READLINE=0
+ABCMKARGS += LIBS="lib/x86/pthreadVC2.lib -s" READLINE=0 CC="$(CXX)" CXX="$(CXX)"
EXE = .exe
else ifneq ($(CONFIG),none)
diff --git a/kernel/log.cc b/kernel/log.cc
index 2cae6a63..19eb38c7 100644
--- a/kernel/log.cc
+++ b/kernel/log.cc
@@ -21,7 +21,7 @@
#include "libs/sha1/sha1.h"
#include "backends/ilang/ilang_backend.h"
-#ifndef _WIN32
+#if !defined(_WIN32) || defined(__MINGW32__)
# include <sys/time.h>
#endif
@@ -51,7 +51,7 @@ static struct timeval initial_tv = { 0, 0 };
static bool next_print_log = false;
static int log_newline_count = 0;
-#ifdef _WIN32
+#if defined(_WIN32) && !defined(__MINGW32__)
// this will get time information and return it in timeval, simulating gettimeofday()
int gettimeofday(struct timeval *tv, struct timezone *tz)
{