summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitignore3
-rw-r--r--Makefile9
-rw-r--r--libs/svgviewer/.gitignore5
-rw-r--r--passes/dfflibmap/Makefile.inc6
4 files changed, 18 insertions, 5 deletions
diff --git a/.gitignore b/.gitignore
index 4576d54d..191b9599 100644
--- a/.gitignore
+++ b/.gitignore
@@ -9,6 +9,7 @@ qtcreator.config
qtcreator.creator
qtcreator.creator.user
Makefile.conf
-filterlib
yosys
yosys-config
+yosys-filterlib
+yosys-svgviewer
diff --git a/Makefile b/Makefile
index b20d1771..6d501d4f 100644
--- a/Makefile
+++ b/Makefile
@@ -12,7 +12,7 @@ OBJS += libs/sha1/sha1.o
OBJS += libs/subcircuit/subcircuit.o
GENFILES =
-TARGETS = yosys yosys-config
+TARGETS = yosys yosys-config yosys-svgviewer
all: top-all
@@ -51,6 +51,10 @@ yosys-config: yosys-config.in
sed 's,@CXX@,$(CXX),; s,@CXXFLAGS@,$(CXXFLAGS),; s,@LDFLAGS@,$(LDFLAGS),; s,@LDLIBS@,$(LDLIBS),;' < yosys-config.in > yosys-config
chmod +x yosys-config
+yosys-svgviewer: libs/svgviewer/*
+ cd libs/svgviewer && qmake && make
+ cp libs/svgviewer/svgviewer yosys-svgviewer
+
test: yosys
cd tests/simple && bash run-test.sh
cd tests/hana && bash run-test.sh
@@ -59,10 +63,13 @@ test: yosys
install: yosys
install yosys /usr/local/bin/yosys
install yosys-config /usr/local/bin/yosys-config
+ install yosys-svgviewer /usr/local/bin/yosys-svgviewer
+ install yosys-filterlib /usr/local/bin/yosys-filterlib
clean:
rm -f $(OBJS) $(GENFILES) $(TARGETS)
rm -f libs/*/*.d frontends/*/*.d passes/*/*.d backends/*/*.d kernel/*.d
+ test ! -f libs/svgviewer/Makefile || make -C libs/svgviewer distclean
mrproper: clean
git clean -xdf
diff --git a/libs/svgviewer/.gitignore b/libs/svgviewer/.gitignore
new file mode 100644
index 00000000..b92d91f8
--- /dev/null
+++ b/libs/svgviewer/.gitignore
@@ -0,0 +1,5 @@
+Makefile
+moc_mainwindow.cpp
+moc_svgview.cpp
+qrc_svgviewer.cpp
+svgviewer
diff --git a/passes/dfflibmap/Makefile.inc b/passes/dfflibmap/Makefile.inc
index ed92b299..b4d73fa1 100644
--- a/passes/dfflibmap/Makefile.inc
+++ b/passes/dfflibmap/Makefile.inc
@@ -2,9 +2,9 @@
OBJS += passes/dfflibmap/dfflibmap.o
OBJS += passes/dfflibmap/libparse.o
-TARGETS += filterlib
+TARGETS += yosys-filterlib
GENFILES += passes/dfflibmap/filterlib.o
-filterlib: passes/dfflibmap/filterlib.o
- $(CXX) -o filterlib $(LDFLAGS) $^ $(LDLIBS)
+yosys-filterlib: passes/dfflibmap/filterlib.o
+ $(CXX) -o yosys-filterlib $(LDFLAGS) $^ $(LDLIBS)